Bug 503140 - dhcpv6-client does no longer support radvd.conf manipulation
dhcpv6-client does no longer support radvd.conf manipulation
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dhcpv6 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-29 04:22 EDT by Peter Bieringer
Modified: 2009-06-03 21:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 21:18:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2009-05-29 04:22:26 EDT
Description of problem:
While trying to get prefix delegation to work I found, that current dhcpv6c does no longer support radvd.conf manipulation (while still mentioned in the man page)

Version-Release number of selected component (if applicable):
dhcpv6-client-1.0.22

How reproducible:
Always

Steps to Reproduce:
1. setup proper dhcp6c.conf
2. run dhcp6c
3.
  
Actual results:
radvd.conf is not manipulated, also found no longer the part in the current source code.


Expected results:
Hmm, either direct manipulation or adding a script hook to be able either to manipulate radvd.conf or e.g. a IPv6 dhcp configuration file.

Additional info:
It was seen in the dhcpv6 code one year ago, but it was removed inbetween - what was the reason?
Comment 1 David Cantrell 2009-06-03 21:18:13 EDT
I removed radvd.conf modification in the upstream source in March of 2008.  Personally, having dhcp6c modify the configuration file of another program seems like bad form to me, so I removed it.

The prefix delegation information is useful to radvd, but I would like to come up with a more appropriate way for that information to come in to dhcp6c and have it provide it to whatever other process wants it.  File in /var/lib/dhcpv6 that other processes can poll?  I don't know I'm just brainstorming, but I do know that having dhcp6c modify the configuration file for radvd is bad.  The programs are separate.

Please take this issue to the upstream location (which is also me, but it's a different location for working issues):

http://fedorahosted.org/dhcpv6/

The past year has seen a lot of work go in to dhcpv6, primarily for it to pass various IPv6 Ready certifications.

Note You need to log in before you can comment on or make changes to this bug.