Bug 503185 - Can't open skk-e21.el
Summary: Can't open skk-e21.el
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ddskk
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-05-29 13:53 UTC by Masatake YAMATO
Modified: 2009-11-11 15:03 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-06-24 19:42:37 UTC


Attachments (Terms of Use)
Fixes this bug. (500 bytes, patch)
2009-05-29 13:53 UTC, Masatake YAMATO
no flags Details | Diff
Patch to support building with XEmacs (1005 bytes, patch)
2009-10-29 16:19 UTC, Jerry James
no flags Details | Diff
Source patch for XEmacs (416 bytes, patch)
2009-10-29 16:20 UTC, Jerry James
no flags Details | Diff

Description Masatake YAMATO 2009-05-29 13:53:58 UTC
Created attachment 345907 [details]
Fixes this bug.

Description of problem:

To use ddskk(ddskk-12.2.0-12.fc11.noarch) on emacs(emacs-22.3-11.fc11.x86_64), emacs complains "Can't find skk-e21.el".

In SKK-MK of the ddskk package , which is part of ddskk build system, the version number of emacs is checked to decide whether skk-e21.el should be installed or not. The SKK-MK expects emacs-21 to install skk-e21.el. However, emacs on F11 is emacs-22. There is a gap.

Attached patch is taken from upstream skk code. In the patch mule version is checked instead of emacs version to decide whether skk-e21.el should be installed or not.

Version-Release number of selected component (if applicable):

ddskk-12.2.0-12.fc11.noarch
emacs-22.3-11.fc11.x86_64

How reproducible:


Steps to Reproduce:
1. install the packages.
2. emacs
3. M-x load-library: skk
  
Actual results:

"Can't find skk-e21.el" is messaged.

Expected results:

Skk works fine.

Additional info:

Comment 1 Bug Zapper 2009-06-09 16:47:29 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Jens Petersen 2009-06-22 06:09:57 UTC
Thanks for the patch.

Unfortunately the xemacs part of the build has been breaking fedora builds of ddskk for a long time now - I guess I should just disable xemacs-ddskk for now...

Comment 3 Jens Petersen 2009-06-22 06:11:42 UTC
ddskk should also be renamed to emacs-ddskk or emacs-common-ddskk,
which probably needs a new package review... I don't suppose you
are interested in maintaining it for fedora, Yamato-san? :)

Comment 4 Jens Petersen 2009-06-22 06:45:48 UTC
> Unfortunately the xemacs part of the build has been breaking fedora builds of
> ddskk for a long time now

Ok, I was confused and thinking about ddskk-13.1 I haven't been able to build yet successfully for fedora.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1428775

I'll backport this to f11 and f10.

Comment 5 Fedora Update System 2009-06-22 06:57:40 UTC
ddskk-12.2.0-13.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ddskk-12.2.0-13.fc11

Comment 6 Jens Petersen 2009-06-22 08:08:07 UTC
> Ok, I was confused and thinking about ddskk-13.1 I haven't been able to build
> yet successfully for fedora.

Nevermind, I finally built ddskk-13.1 for rawhide but had to drop xemacs
since it is still on apel-10.6.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1428851

Comment 7 Fedora Update System 2009-06-22 08:11:53 UTC
ddskk-12.2.0-13.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/ddskk-12.2.0-13.fc10

Comment 8 Ville Skyttä 2009-06-22 14:35:31 UTC
(Changing Cc to current Fedora XEmacs maintainer.)

Comment 9 Jerry James 2009-06-22 16:45:11 UTC
I will take a look at upgrading XEmacs to apel 10.7.

Comment 10 Fedora Update System 2009-06-24 19:42:33 UTC
ddskk-12.2.0-13.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2009-07-03 19:36:25 UTC
ddskk-12.2.0-13.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Jerry James 2009-10-28 17:34:47 UTC
XEmacs has apel 10.7 in F-11+ now, if that matters.  I'm willing to help with any further problems.

Comment 13 Jens Petersen 2009-10-29 07:56:49 UTC
(In reply to comment #12)
> XEmacs has apel 10.7 in F-11+ now, if that matters.

Thanks - good to know, but xemacs-packages-extra.spec still
provides apel-xemacs = 10.6-6.


Also build still fails after that:
http://koji.fedoraproject.org/koji/getfile?taskID=1775997&name=build.log

Comment 14 Jens Petersen 2009-10-29 08:11:03 UTC
more info on the failed build if it helps:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1775997

Comment 15 Jerry James 2009-10-29 14:51:01 UTC
(In reply to comment #13)
> Thanks - good to know, but xemacs-packages-extra.spec still
> provides apel-xemacs = 10.6-6.

Oops.  I've got a font bugfix coming, so I'll fix this at the same time.

> Also build still fails after that:
> http://koji.fedoraproject.org/koji/getfile?taskID=1775997&name=build.log  

Okay, I'll take a look.  Thanks for trying.

Comment 16 Jerry James 2009-10-29 16:19:16 UTC
Created attachment 366657 [details]
Patch to support building with XEmacs

This patch makes a couple of path changes in SKK-CFG for XEmacs.

Comment 17 Jerry James 2009-10-29 16:20:46 UTC
Created attachment 366658 [details]
Source patch for XEmacs

This patch changes two instances of a character defined using the Emacs-only syntax ?\xABC into the syntax ?\uABCD, which is supported by both Emacs and XEmacs.

Comment 18 Fedora Update System 2009-10-29 20:28:36 UTC
xemacs-packages-extra-20090217-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xemacs-packages-extra-20090217-3.fc11

Comment 19 Jerry James 2009-10-29 20:30:39 UTC
I've pushed new builds into F-11, F-12, and devel that fix the apel-xemacs provides.  I've submitted F-11 to testing and requested that the F-12 build be tagged into f12-final.  That plus the patches in comment 16 and comment 17 fix everything for me.  Let me know if there is anything else I can do.

Comment 20 Fedora Update System 2009-11-11 15:03:10 UTC
xemacs-packages-extra-20090217-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.