This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 503190 - After installing the PV drivers on a Windows 2008 64-bit guest, I have two references to the boot disk in Disk Manager.
After installing the PV drivers on a Windows 2008 64-bit guest, I have two re...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xenpv-win (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-29 10:20 EDT by Barry Donahue
Modified: 2010-10-07 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 19:14:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry Donahue 2009-05-29 10:20:25 EDT
Description of problem: After installing the PV drivers, I have 2 boot disk instances. One is QEMU and the other is RHEL SCSI.


Version-Release number of selected component (if applicable):
Windows 2008 64 bit SP1.


How reproducible: only once so far.


Steps to Reproduce:
1. Create and install Windows 2008 64 bit guest.
2. Install PV drivers.
3. reboot.
  
Actual results: There are now to instances of the boot disk. The QEMU instance is the live instance. The RHEL SCSI instance can not be accessed but shows up in Device Manager and Storage Management.


Expected results: The boot disk should be RHEL SCSI.


Additional info:
Comment 1 Perry Myers 2009-05-29 19:14:53 EDT
the xenpv drivers are not supported for boot disks by design.  You can only set secondary (data) disks to use the xenpv (RHEL SCSI) drivers.  The boot disk for Windows must be left as an IDE disk.
Comment 2 Barry Donahue 2009-06-01 10:25:53 EDT
On Windows 2000, Windows XP and Windows 2003 all the disks are RHEL SCSI disks after the PV drivers are installed. We start the boot disk as a QEMU disk then it changes to a RHEL SCSI disk. I'm not sure how this magic works but it does. Secondly, If we want the boot disk to remain QEMU, we shouldn't have a second instance of the disk as a RHEL SCSI device. There is a bug here somewhere.

Note You need to log in before you can comment on or make changes to this bug.