Bug 5032 - ethernet doesn't work after upgrade
ethernet doesn't work after upgrade
Product: Red Hat Linux
Classification: Retired
Component: ftp (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Depends On:
  Show dependency treegraph
Reported: 1999-09-09 16:34 EDT by eduardof
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-12-22 10:08:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description eduardof 1999-09-09 16:34:34 EDT
I am having a problem just after I've tried to upgrade my
Linux from Conectiva RedHat 3.0 to Conectiva 4.0

I've also tried the RedHat 6.0 and Mandrake but,
unfortunately all of these versions have the same problem.

I looked for the answer in the HOW-TO's and tried to install
in all modes but with no success

The problem:

I can 'ping' to all machines in the nework. It works OK.
When I conect to a server using ftp or telnet, after the
answer about my password, the terminal do not answer
If I use Netscape, the browser don't show some pictures and
it hangs.
I cannot use the ftp even inside Netscape.

If I remove the network cable and use a remote conection by
telephone (PPP) all the programs work OK.

Using a tip in one of the HOW-TO's I've got the following
information about the PCMCIA cards:


Socket 0:
product info: "IBM Corp.", "Ethernet", "0934214",
manfid: 0x00a4, 0x0002
function: 6 (network)
Socket 1:
product info: " ", "PCMCIA 33.6/14.4 Data/Fax Modem",
1.51", "Card Assy Part No. 85H8059"
manfid: 0x00a4, 0x0039
function: 2 (serial)


Socket 0:
Vcc = 5.0, Vpp1 = 0.0, Vpp2 = 0.0
Interface type is memory and I/O
IRQ 5 is exclusive, level mode, enabled
Function 0:
Config register base = 0x20000
Option = 0x41, status = 0000, copy = 0000
I/O window 1: 0x0300 to 0x031f, auto sized

Socket 1:
Vcc = 5.0, Vpp1 = 0.0, Vpp2 = 0.0
Interface type is memory and I/O
IRQ 9 is exclusive, level mode, enabled
Speaker output is enabled
Function 0:
Config register base = 0x0200
Option = 0x61, status = 0x08, pin = 0000, ext =
I/O window 1: 0x02f8 to 0x02ff, 8 bit

My laptop is a thinkpad 760EL and I've also tried to upgrade
the BIOS but it didn't fix the problem.

If I change the HD to another with NT or the linux 3.0
inside, everything works. (I've also tried to install in
another hd...)

This is the problem that I cound't solve even swapping the
whole laptop and cards.

I thank you in advance for some help.
Comment 1 bruns 1999-09-21 11:32:59 EDT
I've seen this bug before while dealing with a remote dialup user who
could telnet in, but then it would hang after password prompt.  We
resolved the problem by having him set the MTU size smaller.  The
problem promptly went away.
Comment 2 eduardof 1999-09-22 08:10:59 EDT
Unfortunatelly it didn't work. The results are the same.

Yesteday I installed the RedHat 5.2 (kernel 2.0.xx) and it worked very
All distributions using kernel 2.2.xx don't work.

Couldn't it be a kernel problem?
Comment 3 eduardof 1999-09-29 13:56:59 EDT
I solved the problem. IT was a Kernel problem.
First of all I'd like to thank you for Mr.Rich who send me the start
point like described below:

forum@linuxnow.com wrote:
> henninrp replied to your post 'Kernel problem' at the site: The
Forum.  The Url of this forum is
http://www.linuxnow.com/cgi-bin/wwwthreads/wwwthreads.pl.  The reply
> try going into /usr/src/linux on your working linux drive.  do
> make menuconfig
> find the option to save kernel config. to alternate file.
> save it to a floppy, then put your broken linux install in.  go to
/usr/src/linux, and import the kernel config file from the floppy.
recompuile kernel and then try it.  i don't necessarily think it's
kernel, tho.  did you make sure that all the daemons that need to be
for internet/network connectivity are running?  lemme know.
> -rich henning

Dear Rich:

First of all I'd like to thank you for your reply. It in/directly
helped me to figure out what was the problem.

I did what you had asked me but it didn't solve the problem - the
machine locked in the init level 3.
Searching for some help on the Internet I found a page at IBM telling
about a problem with PCMCIA in versions lower than 2.2.10 and pcmcia
3.0.14 ( http://www.pc.ibm.com/qtechinfo/MIGR-4BP6Q6.html ).

So, I compiled my kernel and pcmcia with these new versions and it

But it's not all. After that I got the newest ISO image from
mandrake's page, with kernel 2.2.13 and pcmcia 3.1.0, burned a CD and
installed it in my laptop.

To my surprise it didn't work!!

I needed to recompile the kernel and pcmcia module to these new
versions to get it working.

So, I think, there were 2 problems related:

First: the kernel and PCMCIA levels.

Second: the pre-compiled versions of these products (mandrake, RedHat
and Conectiva).

Anyway, Your help was the start point to track this problem - THANK
YOU very much.

Best regards.

Eduardo Cruz
Comment 4 Jeff Johnson 1999-12-22 10:08:59 EST
This problem appears resolved.

Note You need to log in before you can comment on or make changes to this bug.