Bug 503206 - Xen networking doesn't support vlan-tagged interfaces
Xen networking doesn't support vlan-tagged interfaces
Status: CLOSED DUPLICATE of bug 514492
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: 5.6
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks: 514500
  Show dependency treegraph
 
Reported: 2009-05-29 11:58 EDT by Jonathan Mills
Modified: 2010-11-09 08:35 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 08:01:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Mills 2009-05-29 11:58:15 EDT
Description of problem: 

Xen, and in particular Xen networking's network-bridge script, does not support the use of vlan-tagged interfaces.  Needless to say, vlans are used widely in enterprise computing, and more to the point, a Xen dom0 is just the sort of box that needs to live on more than one vlan.  This makes the use of Xen a poor option for enterprise-class computing, which is not what I'd expect from "Red Hat Enterprise Linux".  The network-bridge script is a bash script.  There are some descriptions on the web of what one would need to do to alter this script to make it work with vlan-tagged interfaces.  However, most of the descriptions are written with debian in mind, or work with other versions of Xen, or those provided by Xensource.  Ultimately, as an enterprise-class customer, I don't want to be writing my own network-bridge script.  1) I don't trust it.  2) I don't want it to be homemade, I want it to come from Red Hat and be supported.  Even if I could re-write it myself, I doubt Red Hat would support that, and later if I had problems, I'd be out of luck -- which isn't acceptable in a corporate computing environment.  It is my wish for Red Hat to issue a modified version of this script that supports vlan tagging out of the box.


Version-Release number of selected component (if applicable):

Using RHEL 5.3 with the Xen kernel.


How reproducible:

Everytime.


Steps to Reproduce:

Bring up a RHEL 5.3 Xen dom0 on a trunked port with, e.g., two vlans, "vlan 10" and "vlan 20".  Create eth0, eth0.10, eth0.20.  When xend loads at boot time, it will run the network script found in /etc/xen/xend-config.sxp (usually network-bridge).  When that script runs, it will create a bridge on eth0 (which doesn't have an IP) and that just won't get you anything.  It won't recognize that there are other active interfaces (eth0.10 and eth0.20), and thus won't create bridges for them.
  
Actual results:

Out of the box, if you bring up, e.g., vlan-tagged interfaces eth0.10 and eth0.20, and xend loads and runs it's networking scripts, you should have two xen bridges now, called xenbr0.10 and xenbr0.20, to which you can assign a VM using the 'vif' line in the VM's config file, effectively putting the VM on one or the other vlan.

Expected results:

Only xenbr0 is created, and since eth0 never has an IP in such a situation, you actually break the networking on the system.


Additional info:
Comment 1 Jonathan Mills 2009-05-29 12:14:27 EDT
My apologies, in my haste I reversed my responses to the sections "Actual results" and "Expected results".  Please note this and reverse.
Comment 2 Yuval Kashtan 2009-06-22 04:45:53 EDT
ooopppsi
Comment 4 Michal Novotny 2010-06-17 12:16:09 EDT
I was reading about bug 514492 and I think this may be a dup of this one.

What do you think Mirek?

Thanks,
Michal
Comment 5 Miroslav Rezanina 2010-06-18 02:48:06 EDT
No, this are different issues. This bz is for dom0, 514492 is for domU.
Comment 6 Michal Novotny 2010-06-18 07:36:21 EDT
Ok. Thanks for having closer look. It looks familiar but since one is for dom0 and second for domU then those are 2 different issues.

Michal
Comment 7 Michal Novotny 2010-06-28 07:35:58 EDT
Jonathan,
do you think that there should be a bridge per each Ethernet device being up? I.e. xenbr0 for eth0 and also xenbr0.10 for eth0.10 and xenbr0.20 for eth0.20 which is not being supported at the moment? Is my understanding correct?

Michal
Comment 8 Miroslav Rezanina 2010-08-18 08:01:48 EDT
Ok, I were wrong. Testing shows that fix requested by this bz is solving the bz 514492. As I'm going to push patch via bz 514492, closing this ad dup.

*** This bug has been marked as a duplicate of bug 514492 ***

Note You need to log in before you can comment on or make changes to this bug.