Bug 50322 - Missing drivers (cdj970 & hpijs) - byzantine upgrade scheme
Missing drivers (cdj970 & hpijs) - byzantine upgrade scheme
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: printtool (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-30 09:12 EDT by Bryce Nesbitt
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-20 13:14:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bryce Nesbitt 2001-07-30 09:12:22 EDT
This bug report starts by noting the two printer drivers I want are
not included:
	cdj970	- Driver supporting duplexing (2-sided printing) on HP.
	hpijs	- HP's official semi-free driver for HP inkjet printers.

But it continues.  It appears printing is now so "automatic" and 
"microsoft like" that I can't just select a printer driver, I must use 
the (possibly correct) printer database.  That's OK, I suppose, but 
moving in the wrong direction.

The bug report continues.  With most things RedHat and Linux the 
configuration files (while never documented by RedHat) are easy to parse. 
 The files affected by a RedHat GUI (while never documented by RedHat) 
can be easily found.  Not so with printing any more.

Even HP http://hpinkjet.sourceforge.net/binaryinstall.php and 
LinuxPrinting http://www.linuxprinting.org indicate that whatever RedHat 
has done with "alchemist" (and whatever that is), is too much.  RedHat 
seems to have rendered this subsystem non-upgradable.

Please don't do that.  Let us have a modular, upgradable printing 
subsystem.  I don't want to rip out the RedHat printing and start from 
scratch.  Please provide some path to get new drivers in, and either use 
standard setups, or document the weirdness.
Comment 1 Crutcher Dunnavant 2001-07-30 18:10:44 EDT
well.

The ghostscript I've put together for the next release is all singing and all
dancing, so you should have fewer driver issues.

The printing database comes from www.linuxprinting.org, and is my best bet.

I am working /towards/ modular, but am not there yet. The old printtool approach
was anything but, people were just used to hacking on it.

Alchemist is /much/ better documented in the new version, and the python
bindings are clean. The underlying data layer makes some very sweet
configuration merging possible, but again, only rudimentary support exists so far.

Anyway. This bug seems to be: "I liked it the old way, and I want explicit control"

Well, I hated the old way, and I want to give you explicit control. I am trying
to add an "explicit" option, for people who know what they are doing; but I dont
want to add a bad one.

In general, explicit bugs get better results than "I dont like it."
Comment 2 Bryce Nesbitt 2001-07-30 21:59:05 EDT
Actually it's more of a "I'm so confused by the mess I have not the foggiest
idea what to suggest".  The ability to take up-to-date or beta releases of
Ghostscript / Foomatic and the like is certainly part of it.

Some man pages for the redhat tools -- giving some clue as to what the effect,
would also be a part of it.
Comment 3 Arthur Kahlich 2001-08-20 13:14:31 EDT
Like bryce, I also want to be able to install those exact two drivers mentioned
above, cdj970 (from www.harsch.net) and hpijs from HP (could it be we both have
the HP970Cxi and bought it because of its duplex feature?).  Is there any info 
available at all to help in adding printer drivers in the current scheme?  I 
just want to be able to get on with life...
Comment 4 Crutcher Dunnavant 2001-08-28 00:40:27 EDT
I am now off of the hack line for the next release. We use a standard foomatic
backend now, AND the cdj970 driver is compiled in and the hpijs drivers work if
you download them from HP.

Note You need to log in before you can comment on or make changes to this bug.