Bug 503241 - e2fsprogs-1.41.4-6.fc11 does not support external journals
e2fsprogs-1.41.4-6.fc11 does not support external journals
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
http://e2fsprogs.sourceforge.net/e2fs...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-29 15:43 EDT by Ben Galliart
Modified: 2009-06-02 15:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-02 15:32:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Galliart 2009-05-29 15:43:18 EDT
Description of problem:
mke2fs -O journal_dev creates invalid external journal

Version-Release number of selected component (if applicable):
1.41.4-6.fc11

How reproducible:
Always

Steps to Reproduce:
1. Assuming available block devices sdb1 and sdc1
2. mke2fs -O journal_dev /dev/sdb1
3. mke2fs /dev/sdc1
4. tune2fs -o journal_data -j -J device=/dev/sdb1 /dev/sdc1
  
Actual results:
tune2fs returns:
tune2fs: Filesystem has unexpected block size
        while trying to open journal on /dev/sdb1

Expected results:
tune2fs 1.41.5 (23-Apr-2009)
Creating journal on device /dev/sdb1: done
This filesystem will be automatically checked every 36 mounts or
180 days, whichever comes first.  Use tune2fs -c or -i to override.

Additional info:
Problem is acknowledged as fixed in release notes for e2fsprogs 1.41.5.  I am able to confirm the problem is fixed by using 1.41.5 instead of the Fedora 11 provided mke2fs.
Comment 1 Eric Sandeen 2009-05-29 16:26:09 EDT
You just missed it ;)

* Wed Apr 22 2009 Eric Sandeen <sandeen@redhat.com> 1.41.4-8
- Fix support for external journals

Can you try the more recent e2fsprogs in F11?  (it should be tagged for F11 already...)

Thanks,
-Eric
Comment 2 Eric Sandeen 2009-06-02 15:32:23 EDT
currentrelease, rawhide... it's all confusing right now :)  but anyway this should be fixed.

Note You need to log in before you can comment on or make changes to this bug.