Bug 503245 - Update package search APIs to include channel as part of the query
Update package search APIs to include channel as part of the query
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2009-05-29 16:50 EDT by Jay Dobies
Modified: 2014-07-04 09:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-04 09:25:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Dobies 2009-05-29 16:50:48 EDT
With the changes made to support BZ 457316, the web UI now offers some channel filtering options for package searches that aren't fully supported by the XMLRPC APIs for this functionality. This BZ is to address if those changes should be added to the APIs as well, and if so to track that they get done.

It's not a trivial (i.e. 30 minute) fix, so I filed a separate BZ to let it get triaged for 5.3 rather than just making the API change as I updated the web UI.
Comment 2 Jan Pazdziora 2012-03-15 08:32:18 EDT
I believe this is a dupe of bug 457350 which added packages.search.advancedWithChannel and could be closed as such.

Note You need to log in before you can comment on or make changes to this bug.