Bug 503260 - qtconfig-qt4 does not recognize that gstreamer backend is around
qtconfig-qt4 does not recognize that gstreamer backend is around
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-29 22:56 EDT by Francis Earl
Modified: 2009-06-05 19:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-05 19:35:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francis Earl 2009-05-29 22:56:10 EDT
Description of problem:
Due to Phonon not being compiled with support for Gstreamer directly, qtconfig-qt4 never allows you to configure this backend.

Version-Release number of selected component (if applicable):
qt-4.5.0-14.fc11.x86_64
phonon-4.3.1-4.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Load up qtconfig-qt4
2. Go to the phonon settings tab
3. Notice everything is blanked out
  
Actual results:
No configuration of Gstreamer for use with Qt, although it doesn't seem to effect KDE apps in my configuration.

Expected results:
I should be able to configure the gstreamer backend from this tab if something isn't right with my setup.
Comment 1 Kevin Kofler 2009-05-29 23:00:50 EDT
As I said on IRC, the issue there is that availability of the GStreamer backend is checked at compile time:
http://websvn.kde.org/trunk/qt-copy/tools/qtconfig/mainwindow.cpp?revision=958369&view=markup
rather than at runtime (which is arguably an upstream bug). The effect is that due to how our packaging works, we end up with those settings not being available.

Now we don't really support phonon-backend-gstreamer nor qtconfig-qt4 (which we hide in the menus), so I'm not sure what priority to give to this, but I agree this is screwed up.
Comment 2 Kevin Kofler 2009-05-29 23:03:30 EDT
And the reason it's done that way is because qtconfig-qt4 does direct GStreamer calls to figure out the available sinks. Yuck! (The way the Phonon GStreamer backend handles sinks is completely broken, this needs to be exposed through the Phonon API, qtconfig-qt4 has no business calling GStreamer directly.)
Comment 3 Kevin Kofler 2009-06-05 19:35:01 EDT
Than enabled building Qt's internal Phonon, including the GStreamer backend, in F12 Rawhide, so qtconfig-qt4 should be picking it up now.

Note You need to log in before you can comment on or make changes to this bug.