Bug 503274 - libata doesn't detects pata with ICH7
libata doesn't detects pata with ICH7
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-30 10:51 EDT by Jonas Jonsson
Modified: 2010-06-28 08:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:45:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonas Jonsson 2009-05-30 10:51:01 EDT
Description of problem:
I'm trying to install Fedora 11 preview on Intel SS4200-EHW. The motherboard has a Intel ICH7 chipset with 4 sata ports and one pata. The problem is that ata_piix doesn't detect the pata disks, (Two Kingston 4Gb CompactFlash, tried a normal pata disk as well). Bios detects the disk just fine and the EDD module reports 6 disks which is correct.

IDE mode in bios, ata_piix detects the sata disks
sh-4.0# lspci -nn -s 00:1f.2
00:1f.2 IDE interface [0101]: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller [8086:27c0] (rev 01)

AHCI mode in bios, ahci driver detects the sata disks
sh-4.0# lspci -nn -s 00:1f.2
00:1f.2 SATA controller [0106]: Intel Corporation 82801GR/GH (ICH7 Family) SATA AHCI Controller [8086:27c1] (rev 01)

If I boot a Gentoo minimal installation (20090526) CD that has the old IDE layer, the kernel detects the pata disks.

Version-Release number of selected component (if applicable):
2.6.29.1-102.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot Fedora 11 Preview on Intel SS4200-EHW
2. Installer doesn't show any pata disks.
3. *Sigh*
  
Actual results:
No pata disks detect.

Expected results:
Pata disks detect

Additional info:
Comment 1 Jonas Jonsson 2009-06-05 10:41:35 EDT
Some more information:

By using the old IDE driver ide-generic I've been able to get my pata devices detected. But I only get 1-2MB/s, from what I've read it's because the driver can't enable DMA.

If I change to "compatible" in BIOS I only get four drives instead of six. But the four detected drives (two sata, two pata) works. I get ~43MB/s from pata and over 100MB/s from sata.
Comment 2 Jonas Jonsson 2009-06-06 11:25:07 EDT
I've tried with Fedora-11-RC4-x86_64-DVD and there aren't any changes.
Comment 3 Jonas Jonsson 2009-06-12 14:47:31 EDT
Same with Fedora-11-x86_64-DVD.
Comment 4 Bug Zapper 2010-04-27 10:35:12 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2010-06-28 08:45:39 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.