Bug 503291 - Extreme amounts of ACPI errors and exceptions, causing CPU usage and heat due to the amount.
Extreme amounts of ACPI errors and exceptions, causing CPU usage and heat due...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-30 17:05 EDT by nopycckn
Modified: 2013-01-10 02:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 04:30:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
message log (11.99 KB, text/plain)
2009-06-02 09:50 EDT, nopycckn
no flags Details

  None (edit)
Description nopycckn 2009-05-30 17:05:36 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10) Gecko/2009042708 Fedora/3.0.10-1.fc10 Firefox/3.0.10

I'm using an HP a1050y desktop. I have two HyperThreaded 3.4 GHz Pentium 4 processors. I believe my BIOS to be up-to-date. I am getting repeated ACPI errors and exceptions in my logs, and they are affecting my (Alt+Ctrl+F1,F2,F3,etc.) shell, also. They repeatedly show up in my log files and bash shell. They show up in messages, very often, and when they do show up when I'm using the bash shell, it can be extremely interruptive. I'm using Fedora 10. I have kernel 2.6.27.24-170.2.68.fc10.i686 using uname -a. The way the system is configured, which is the default installation, I don't have many log files available to me under System Log, for whatever reason. These messages are only showing up under the MESSAGES log. A copied section of the messages is attached.
I have whole message files filled with nothing but this repeated set of errors and exceptions.
I've tried another distribution of Linux, before this one, and it happened there, too, only it didn't affect the bash shell using Alt+Ctrl+F*, and didn't repeat NEARLY as often.


How reproducible:
Every single time I turn the computer on, for as long as the computer is on, repeating constantly.

Additional info:
I'm not having any apparent problems, except I believe it may be causing my cpu fan to come on and off regularly, because while it's repeating my fan will often whir-and-stop, whir-and-stop, whir-and-stop, like there's a rhythm to the heat, much like the messages. When using the system monitor, it does show my cpu to be constantly doing something similar to this, but very low amounts of cpu usage AT A TIME:
..|..|..|..|..|..|..|..|..|..|..|..|..|..|
it will CONSTANTLY have tiny spikes repeating over and over again, while my cpu fan whirs-and-stops and whirs-and-stops. I'm not having any other apparent problems. The fact that they interrupt my Alt+Ctrl bash shells and show up on shutting down, also, make it much more severe for me, I don't want to say URGENT, so I'm using HIGH, but I consider it PERSONALLY URGENT.

Reproducible: Always

Steps to Reproduce:
Turning the computer on.
Comment 1 Steven M. Parrish 2009-05-30 22:54:21 EDT
Reassigning to the correct component
Comment 2 Zdenek Prikryl 2009-06-02 07:54:57 EDT
You didn't attach log file ($ cat /var/log/messages | grep acpid). Please attach it. Thanks.
Comment 3 nopycckn 2009-06-02 09:50:31 EDT
Created attachment 346252 [details]
message log

This is the first 100 lines of the file, but this particular file (at the time of writing) is 146,965 lines long!
Comment 4 nopycckn 2009-06-02 09:57:44 EDT
I wasn't sure what to choose for component. I know now that acpid must be the wrong component. I don't know what the component would be, but the errors and exceptions are obviously ACPI errors and exceptions. I don't know what to choose as the component - should I change it? Also, I choose i686 as the platform and my uname -m is i686, but I do use two hyperthreaded Pentium 4's - not sure if that's important. I changed the severity to urgent, because I find it to be, but I'm not sure what exactly would classify as urgent.
Comment 5 Zdenek Prikryl 2009-06-02 10:38:27 EDT
The platform is chosen correctly. The proper component should be kernel, so I'm reassigning it.
Comment 6 Chuck Ebbert 2009-06-04 01:55:53 EDT
ACPI Error (psargs-0358): [\_TZ_.THRM] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0530): Method parse/execution failed [\_GPE._L1C] (Node f7817450), AE_NOT_FOUND
ACPI Exception (evgpe-0573): AE_NOT_FOUND, while evaluating GPE method [_L1C] [20080609]
ACPI Error (psargs-0358): [\_TZ_.THRM] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0530): Method parse/execution failed [\_GPE._L1C] (Node f7817450), AE_NOT_FOUND

Can you try the 2.6.29.4-75 kernel from the updates-testing repository?
Comment 7 nopycckn 2009-06-15 22:49:19 EDT
I've never tried changing the kernel, and am worried about it causing problems, because it's time consuming to reinstall and update, etc. I don't know much about changing the kernel, I've never tried to. I should also say that the fan seems to whir much more often when it's warmer or when a program is already being executed, since it gives it a nudge to the point where the fan will come on. If I have no programs running, except, say, reading something or using a terminal, it doesn't appear to happen unless it's warm in the room. It needs to be given a little push to get it warm enough. Regarding the kernel, I just don't want to have to reinstall and update again, really, because it's time consuming and I've spent a lot of time trying Fedora and another distribution and different options, etc. lately and have spent a fair amount of time on it, already.
Comment 8 nopycckn 2009-06-16 23:26:30 EDT
I know this isn't a support site, but I was wondering if you think if I try the 2.6.29.4-75 kernel I could do so without causing serious problems and having to reinstall, etc. I've very recently used Ubuntu 9.04 on this computer, and received the same messages, but far fewer of them. According to the Ubuntu site: "Ubuntu 9.04 includes the 2.6.28-11.37 kernel based on 2.6.28.8".
Comment 9 nopycckn 2009-06-17 10:37:51 EDT
Never mind. I installed the 2.6.29.4-75 kernel and it isn't helping.
Comment 10 nopycckn 2009-06-17 10:40:53 EDT
I have additional information, very important. I didn't realize this until now. As soon as the fan comes on, the messages stop. As soon as the fan goes off, the messages start up again. Still the exact same messages. I never realized they stopped when the fan came on, until I monitored it with the room warm and the fan coming on normally, not whirring and stopping, but just coming on occasionally. I get the messages constantly when it's not active.
Comment 11 Chuck Ebbert 2009-06-20 07:37:08 EDT
(In reply to comment #11)
> I've tried another distribution of Linux, before this one, and it happened
> there, too, only it didn't affect the bash shell using Alt+Ctrl+F*, and didn't
> repeat NEARLY as often.
> 

You can disable the console messages by running this command:

  setterm -msg off
Comment 12 nopycckn 2009-06-26 23:15:18 EDT
"High  	 Problem due to crashes, loss of data, severe memory, leak, etc."
I probably should've used Medium for severity. The Alt+Ctrl+F* shell being affected I also considered extremely serious.
Comment 13 Chuck Ebbert 2009-06-30 23:18:16 EDT
Can you attach the /var/log/dmesg file from that system? It should have the kernel boot messages in it.
Comment 14 nopycckn 2009-07-02 02:16:54 EDT
Sorry, I can't now. I'm using Ubuntu now.
Comment 15 Bug Zapper 2009-11-18 04:30:26 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Bug Zapper 2009-12-18 04:30:30 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.