Bug 503317 - openttd lose mouse/keybord input
openttd lose mouse/keybord input
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openttd (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Felix Kaechele
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-31 05:28 EDT by Alexey Kuznetsov
Modified: 2009-06-21 07:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-21 07:15:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Kuznetsov 2009-05-31 05:28:39 EDT
After some action openttd lose input. It no longer act on mouse/keyboard events, without any other effect in game (tracs still move, air planes still fly)
Comment 1 Felix Kaechele 2009-05-31 08:27:25 EDT
Did you try changing the Video driver from Allegro to SDL? That not only improved performance for me but also got rid of that problem. Change the settings in ~/.openttd/openttd.cfg
Comment 2 Alexey Kuznetsov 2009-05-31 09:23:00 EDT
Man, its 10 time faster!!! Why its not default?

I will check bug, and report if problem persist
Comment 3 Alexey Kuznetsov 2009-05-31 15:27:45 EDT
played for several hours - no bug present in SDL
Comment 4 Bug Zapper 2009-06-09 12:52:45 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Felix Kaechele 2009-06-21 07:15:14 EDT
Closing. OpenTTD is now built without allegro (which actually was intended to make OpenTTD compatible with DOS). Thus this error has disappeared. It will however still be reported upstream.

Note You need to log in before you can comment on or make changes to this bug.