Bug 50337 - Anaconda and NT?
Anaconda and NT?
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-30 12:01 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-03 11:22:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-30 12:01:34 EDT
Hi!

My question is rather general and does not only concern RH7.1 but concerns
also the previous releases.
Why a NTFS partition (NT4 or W2k) does not show up during the Lilo
configuration during the installation Anaconda?

At home I have a Fat32 Windows 98 partition which is seen at once by
Anaconda and added to the list of OSes Lilo can boot.
Here at work I have 2 machines with disks:
Disk 1 (SCSI or EIDE, same problem) : Windows NT (4 and W2k)
Disk 2 : RedHat 7.1

During the installation, the NTFS partition is never seen and I have to
boot with a disquette (I am not a lilo.conf guru and I DON'T WANT TO BE...
I have had too many problems with it) because I want a Lilo with NT and
Linux and nothing else.


So, how can I modify my lilo.conf file and... why is NTFS not seen by
Anaconda?


Daniel
Comment 1 Brent Fox 2001-08-03 11:22:14 EDT
The partitioning detection code in 7.1 didn't always identify NTFS partitions
correctly.  We have completely replaced this code for the next version of Red
Hat Linux.  Also, we use the GRUB bootloader by default in the next version, and
it seems to be much better at handling NTFS partitions.  The installer will now
detect NTFS partitions and present them in the bootloader configuration screen.
 These new features are available in the public beta(Roswell) we released a few
days ago.

Having said that, that doesn't help your current situation much.  I think if you
were to add a section to your lilo.conf file, it may allow you to boot NT.

Add a section to the end of your lilo.conf file that looks like:

other=/dev/hda1
        label=winNT
        table=/dev/hda

Of course, the above assumes that you are using IDE drives with NT on the first
partition.  For your SCSI drives, try:

other=/dev/sda1
        label=winNT
        table=/dev/sda

Let me know if that works for you.  We received a number of these complaints, so
we have addressed these issues for future releases.

Note You need to log in before you can comment on or make changes to this bug.