Bug 50338 - [4.1]: rpm dependency messages should give installed status
Summary: [4.1]: rpm dependency messages should give installed status
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-30 16:17 UTC by NILMONI DEB
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-09 19:02:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description NILMONI DEB 2001-07-30 16:17:17 UTC
Description of Problem:


This is just a wishlist. During "rpm -ivh some_pkg.rpm" the libraries needed (but not


installed) by some_pkg.rpm and those which conflict with existing libraries are listed


out as :





        libxyz.so.3   is needed by some_pkg


        libuvw.so.3   is needed by old_pkg





Its not clear from this message that  libxyz.so.3 is an unistalled one while libuvw.so.3


is already installed. Also its not evident that old_pkg is an installed rpm.


Perhaps a message such as :





        libxyz.so.3   is needed by some_pkg


        libuvw.so.3(installed)  is needed by current old_pkg





will be more helpful, particularly when such lists are large. In that case the user will


not have to do "rpm -q .." to find which pkg is installed and which is not.





How Reproducible:








Steps to Reproduce:


1. 


2. 


3. 





Actual Results:








Expected Results:








Additional Information:

Comment 1 Jeff Johnson 2001-07-31 14:18:04 UTC
This is a good idea, dunno if I can get into rpm-4.0.3, but will
try to get in soon thereafter.

Thanks for the report.

Comment 2 Jeff Johnson 2001-12-09 19:02:28 UTC
This is still a good idea, but, since it changes the error
message that is wired into rpm python bindings and
such, it's gonna take some work. I'm gonna mark
"4.1" in the subject, trying to get the work prioritized.

Comment 3 Jeff Johnson 2002-06-28 21:44:46 UTC
Fixed in rpm-4.1-0.36 when built.


Note You need to log in before you can comment on or make changes to this bug.