This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 50340 - Can't mount NFS exported volumes from Novell NFS server
Can't mount NFS exported volumes from Novell NFS server
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-30 12:54 EDT by Josep M. Gorro
Modified: 2007-04-18 12:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-05 13:27:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Josep M. Gorro 2001-07-30 12:54:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Win98; I)

Description of problem:
I have a RH 7.1 that can't mount an exported volume from a Netware 5.1 server with NFS services up and running with the error:
Invalid filesystem type, incorrect option, bad superblock or too many filesystems mounted.
If I export a folder under the Netware volume all goes fine.
I perform the same test from a RedHat 6.1 box and both tests runs without problems.
The RH7.1 has the package nfs-utils-0.3.1-5
The RH6.1 has the package knfsd-clients-1.4.7-7 and knfsd-1.4.7-7


How reproducible:
Always

Steps to Reproduce:
1. mount <netware_computer>:/<shared_resource> /mnt/netware
shared_resource is a volume exported from NFS Novell services 


Actual Results:  mount: incorrect file system type, incorrect option, bad superblock on <netware_computer>:/<shared_resource>
or too many mounted file systems

Expected Results:  mount successful

Additional info:

If the export is a subdir from the netware volume all goes fine.
The same test from a RH6.1 box runs in all cases.
Comment 1 Bob Matthews 2001-07-30 14:07:38 EDT
Sounds like the NCP kernel module is not loaded.

Does lsmod show the ncpfs module?

If not, can you mount the Netware volume after inserting the modules by hand
with the command "insmod ncpfs"?
Comment 2 Josep M. Gorro 2001-07-31 02:01:16 EDT
Hello again:
The NCPFS package isn't required because I would to connect my RH7.1 boxes to a Netware cluster services (only runs in TCP/IP). For this reason I 
had install the NFS services for Netware. The rcpinfo -p command to one Netware server tells me that all possible NFS daemons are running (from 1 to 3 
versions and in TCP and UDP protocols) and the portmapper is running in port 111 and the showmap -e of the same netware server tells me all the 
exported directories with it's trustees. I would to nottice you that if I export a directory (not the volume root) from the Netware server, the mount command 
is performed successfully without NCP
It sounds like the NFS client or the portmapper is running wrong because the RH6.1 can mount or the exported volume or the exported directory without 
problems.
Actually I have a NW4.11 servers with the clients connected using the NCP package and IPX protocol.
Today I try to remove the nfs-utils package from the RH7.1 and install an older package (from RH7.0 or RH6.2).
If you would I can tell you the results.
Comment 3 Josep M. Gorro 2001-07-31 03:57:40 EDT
I perform another test.
I install RH7.0 (without any update) on a computer and the mount process as described earlier works fine.
On the same machine I perform an OS update to RH7.1 and now the problem appears again but now, in the syslog, appears the followin messages:
Jul 31 11:55:41 localhost kernel: NFS: Buggy server - nlink == 0!
Jul 31 11:55:41 localhost kernel: __nfs_fhget: iget failed
Jul 31 11:55:41 localhost kernel: nfs_get_root: getattr error = 116
Jul 31 11:55:41 localhost kernel: nfs_read_super: get root inode failed
Jul 31 11:55:41 localhost kernel: nfs warning: mount version older than kernel
Jul 31 11:55:41 localhost kernel: NFS: Buggy server - nlink == 0!
Jul 31 11:55:41 localhost kernel: __nfs_fhget: iget failed
Jul 31 11:55:41 localhost kernel: nfs_read_super: get root inode failed
Any workarround?
Comment 4 Pete Zaitcev 2003-12-05 13:27:39 EST
Stale - closing regretfuly.

Note You need to log in before you can comment on or make changes to this bug.