Bug 503422 - mapnik python module doesn't import
mapnik python module doesn't import
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mapnik (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-31 17:35 EDT by Russell Harrison
Modified: 2009-07-03 15:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.5.2-0.8.svn738.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-03 15:55:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Harrison 2009-05-31 17:35:54 EDT
Description of problem:
I'm unable to import the mapnik python module.

Version-Release number of selected component (if applicable):
$ rpm -q mapnik-python
mapnik-python-0.5.2-0.7.svn738.fc10.i386

How reproducible:
Every time

Steps to Reproduce:
1. Run python from the command line
2. import mapnik
  
Actual results:
>>> import mapnik
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.5/site-packages/mapnik/__init__.py", line 31, in <module>
    from _mapnik import *
ImportError: /usr/lib/libmapnik.so.0.5: undefined symbol: _ZN5Cairo7Context15set_font_matrixERK13_cairo_matrix

Expected results:
The module imports cleanly.

Additional info:
Comment 1 Russell Harrison 2009-05-31 18:13:05 EDT
I downloaded the src.rpm for the mapnik packages and recompiled it with mock.  This seems to have resolved the issue for me.  Because of the font changes for F11 I was unable to get the latest release of the package to build but rebuilding the same version already on F10 built just fine.
Comment 2 Alex Lancaster 2009-06-30 00:11:12 EDT
I can reproduce this on F-10.  I'll look into rebuilding for both F-10 and F-11.

(I recently rebuilt it for F-12/rawhide).
Comment 3 Fedora Update System 2009-06-30 01:19:59 EDT
mapnik-0.5.2-0.8.svn738.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/mapnik-0.5.2-0.8.svn738.fc10
Comment 4 Russell Harrison 2009-07-01 12:12:24 EDT
I have downloaded and installed the packages from koji and they seem to fix the import problem.  I also tested the "hello world" tutorial which also worked as expected.
Comment 5 Fedora Update System 2009-07-02 01:54:24 EDT
mapnik-0.5.2-0.8.svn738.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mapnik'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-7284
Comment 6 Fedora Update System 2009-07-03 15:55:29 EDT
mapnik-0.5.2-0.8.svn738.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.