Bug 503424 - k3b shows bad CDDB lookup information.
k3b shows bad CDDB lookup information.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: k3b (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-31 18:08 EDT by Rick Wagner
Modified: 2014-01-12 19:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 22:06:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 194868 None None None Never

  None (edit)
Description Rick Wagner 2009-05-31 18:08:15 EDT
Trying to rip audio CD, k3b does a CDDB query, and returns with a dialog with the message "K3b found multiple inexact CDDB entries.  Please select one."

In the selection box, the list of entries has one entry: "1 - (_)" (where the _ is a hollow square, probably an invalid character code).

Other apps (asunder) will correctly retrieve data for the same CDs.

Version-Release number of selected component (if applicable):
k3b-1.0.5-8.fc11.x86_64


How reproducible:


Steps to Reproduce:
1. Start K3b
2. Load audio CD into drive
3. Click on the drive
  
Actual results:
K3b says it is retrieving CDDB entry, then returns with above mention dialog, even if the disk has a unique entry according to other apps.


Expected results:
K3b will display CD information (if unique entry), or a valid list of alternatives.

Additional info:
Comment 1 Rex Dieter 2009-06-01 07:50:40 EDT
Last I tried (admittedly awhile ago), it worked well.  Is this reproducible with any audio cd, or just 1 (or 2) you tried?
Comment 2 Rick Wagner 2009-06-01 13:22:15 EDT
This is reproducible with all audio CD's I tried (3 or 4).  To verify reproducibility, I also tried this on a i586 install on a different system, and the behavior was the same.

On both these system, this was a mostly KDE install, i.e. on the installation, I deselected Gnome desktop, and selected KDE.  Both systems were running with current "yum updates".
Comment 3 Steven M. Parrish 2009-06-02 08:24:48 EDT
Thank you for taking the time to report this issue.

This is an issue that needs to be addressed by the upstream developers. Please report this at http://bugs.kde.org and then add the upstream report information to this report.  We will monitor the upstream report for a resolution to this issue.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Rick Wagner 2009-06-03 02:40:10 EDT
I found that it already exists as http://bugs.kde.org/show_bug.cgi?id=194868.  It was originally reported there for F10, reconfirmed for F11 and Kubuntu 9.04.
Comment 5 Rick Wagner 2009-06-03 21:56:55 EDT
Updates to the bug at KDE reveal this was apparently a bug (link in comment #4 above) with the CDDB provider defaulted to by k3b (freedb2.org).  It appears that different tools use different providers, which is why it worked for asunder, but not k3b.  freedb2 has apparently corrected their site, and k3b now works.

Sorry for the false bug.
Comment 6 Rex Dieter 2009-06-03 22:06:16 EDT
Thanks Rick, stellar detective-work.

Note You need to log in before you can comment on or make changes to this bug.