Bug 503433 - The name of keyboard type that fit to my Brazilian (pt-BR) Thinkpad R61 is wrong. [NEEDINFO]
The name of keyboard type that fit to my Brazilian (pt-BR) Thinkpad R61 is wr...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-31 22:23 EDT by Davi Vercillo C. Garcia
Modified: 2010-06-28 08:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:46:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mcepl: needinfo? (davivercillo)
peter.hutterer: needinfo? (davivercillo)


Attachments (Terms of Use)
Output of command "setxkbmap -print". (262 bytes, text/plain)
2009-06-11 17:03 EDT, Davi Vercillo C. Garcia
no flags Details
Xorg log file. (36.07 KB, text/plain)
2009-06-11 17:10 EDT, Davi Vercillo C. Garcia
no flags Details
Keyboard layout photo. (452.29 KB, image/jpeg)
2009-07-12 23:54 EDT, Davi Vercillo C. Garcia
no flags Details

  None (edit)
Description Davi Vercillo C. Garcia 2009-05-31 22:23:32 EDT
Description of problem:
There isn't any keyboard layout that fit to my Brazilian(pt-BR) Thinkpad R61. Using the included options, some keys doesn't work (like "/" and "?").

Additional info:
In another GNU/Linux distribution, like Debian Lenny, my keyboard works right with the follow configurations on xorg.conf:

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"thinkpad"
	Option		"XkbLayout"	"br"
	Option		"XkbVariant"	"abnt2"
EndSection
Comment 1 Matěj Cepl 2009-06-10 19:11:20 EDT
Actually, we should have all the parts from your Debian configuration present in Fedora. Could you try to run X without xorg.conf and then try to make your keyboard working just with Gnome tools (gnome-keyboard-properties). If you can make it working could you post here output of setxkbmap -print, please? Also, just to see what Fedora thinks about your keyboard, could we get /var/log/Xorg.0.log, /var/log/dmesg, and (if you have any) /etc/X11/xorg.conf attached to this bug as separate uncompressed attachments, please?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Davi Vercillo C. Garcia 2009-06-11 17:03:22 EDT
Created attachment 347474 [details]
Output of command "setxkbmap -print".
Comment 3 Davi Vercillo C. Garcia 2009-06-11 17:09:29 EDT
Comment on attachment 347474 [details]
Output of command "setxkbmap -print".

With this layout, the most of keys works fine. But I still cannot use "question mark", "slash (not \)", "some regional accents", etc. This output is from Fedora 11 (I've tried the same configuration at RHEL 5.3).
Comment 4 Davi Vercillo C. Garcia 2009-06-11 17:10:49 EDT
Created attachment 347477 [details]
Xorg log file.

The log file of Xorg, on Fedora 11.
Comment 5 Davi Vercillo C. Garcia 2009-06-11 17:13:32 EDT
Some additional informations was added to bug report, as required by Matej Cepl.
Comment 7 Matěj Cepl 2009-06-16 09:31:57 EDT
(In reply to comment #4)
> The log file of Xorg, on Fedora 11.  

OK, switching the bug to Fedora 11 product.
Comment 8 Peter Hutterer 2009-06-16 18:25:23 EDT
I don't have an abnt2 keyboard here, so I can't test directly. this command should give you the right layout.

setxkbmap -layout br -model abnt2

should set everything correctly. If this works for you, please go to the keyboard configuration option and click on the keyboard model button - the right model is in Generic - Brazilian ABNT2. 

Did this work for you?
Comment 9 Davi Vercillo C. Garcia 2009-07-12 23:54:00 EDT
Hi,

Both ways didn't work for me. I'm sending a photo of my keyboard layout.

Thanks.
Comment 10 Davi Vercillo C. Garcia 2009-07-12 23:54:46 EDT
Created attachment 351424 [details]
Keyboard layout photo.
Comment 11 Peter Hutterer 2009-07-14 00:12:37 EDT
can you please attach the output of "xkbcomp -xkb :0 -" from the debian box where everything works? Thanks.
Comment 12 Davi Vercillo C. Garcia 2009-07-14 11:05:07 EDT
(In reply to comment #11)
> can you please attach the output of "xkbcomp -xkb :0 -" from the debian box
> where everything works? Thanks.  

Sorry but I'm not using Debian anymore... I'm using (trying at least) Fedora 11. But I had already put all of my Debian's configurations here.
Comment 13 Davi Vercillo C. Garcia 2009-07-27 22:35:49 EDT
Everything worked fine again when I set the model "IBM ThinkPad 560Z/600/600E/A22E" and layout "Brazil" but my model should be "IBM Thinkpad R60/T60/R61/T61".
Comment 14 Fernando Guidorizzi 2009-07-29 08:38:34 EDT
Same problem on T61, and worked with
 "IBM ThinkPad
560Z/600/600E/A22E"
Comment 15 Peter Hutterer 2009-08-18 02:24:45 EDT
can you please verify the following:

setxkbmap -model "evdev" -layout "br"     ... broken
setxkbmap -model "thinkpad" -layout "br"  ... working
setxkbmap -model "thinkpad60" -layout "br" .. broken

the last two should be the same, but they seem to be broken if the t61 model doesn't work but the 560Z do.
Comment 16 Davi Vercillo C. Garcia 2009-08-19 00:14:42 EDT
This is ok !

setxkbmap -model "evdev" -layout "br"     ... broken
setxkbmap -model "thinkpad" -layout "br"  ... working
setxkbmap -model "thinkpad60" -layout "br" .. broken

Thanks.
Comment 17 Matěj Cepl 2009-11-05 13:30:20 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 18 Matěj Cepl 2010-02-26 07:26:12 EST
Could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[Note please, that this is machine generated comment for large amount of bugs; due to some technical issues, it is possible we've missed some of the responses -- it is happens, please, just a make a comment about that; that we will see. Thank you]
Comment 19 Bug Zapper 2010-04-27 10:36:12 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 20 Peter Hutterer 2010-04-27 21:12:02 EDT
is this still an issue with F12 or F13?
Comment 21 Bug Zapper 2010-06-28 08:46:32 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.