Bug 503473 - virt-install: Failed to install guest domain with option xen --hvm --location <url>
virt-install: Failed to install guest domain with option xen --hvm --location...
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-01 04:39 EDT by Nan Zhang
Modified: 2009-12-14 16:18 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-08 11:29:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/xen/xend.log (6.32 KB, text/plain)
2009-06-01 06:52 EDT, Nan Zhang
no flags Details

  None (edit)
Description Nan Zhang 2009-06-01 04:39:53 EDT
Description of problem:
POST operation failed: xend_post: error from xen daemon: (xend.err "Error creating domain: (14, 'Bad address')")
Domain installation may not have been
 successful.  If it was, you can restart your domain
 by running 'virsh start foo'; otherwise, please
 restart your installation.
ERROR    POST operation failed: xend_post: error from xen daemon: (xend.err "Error creating domain: (14, 'Bad address')")
Traceback (most recent call last):
  File "/usr/sbin/virt-install", line 865, in ?
    main()
  File "/usr/sbin/virt-install", line 763, in main
    start_time, guest.start_install)
  File "/usr/sbin/virt-install", line 818, in do_install
    dom = install_func(conscb, progresscb, wait=(not wait))
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 541, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 633, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 974, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: POST operation failed: xend_post: error from xen daemon: (xend.err "Error creating domain: (14, 'Bad address')")

Version-Release number of selected component (if applicable):
rhel-5.4
libvirt-0.6.3-3.el5
libvirt-python-0.6.3-3.el5
python-virtinst-0.400.3-1.el5

How reproducible:
Always

Steps to Reproduce:
# virt-install \
    --hvm \
    --name foo \
    --ram 512 \
    --file /var/lib/xen/images/foo.img \
    --file-size 4 \
    --vnc \
    --location http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL5.4-Server-latest/tree-x86_64/
  
Actual results:
Creating domain error.

Expected results:
Should be no error.

Additional info:
Comment 1 Chris Lalancette 2009-06-01 05:57:36 EDT
I'm pretty sure that --location is incompatible with --hvm in RHEL-5 Xen.  So we should fix libvirtd to disallow that combination.  However, if you want to continue testing, use --hvm with --cdrom to do your installs.

Chris Lalancette
Comment 2 Daniel Berrange 2009-06-01 06:11:11 EDT
Please provide the output of  virt-install with the --debug flag added. Also provide the /var/log/xen/xend.log file.
Comment 3 Nan Zhang 2009-06-01 06:52:41 EDT
Created attachment 346073 [details]
/var/log/xen/xend.log

Chris,
Yes, I used --cdrom to do the testing for fully-virt. Also, I think the option "Network install tree(HTTP,FTP,or NFS)" should be disabled in virt-manager when you select "Fully virtualized" to install guest.


Daniel,
Run virt-install again with the --debug flag. Attached xend.log for your reference.


Thanks!
Comment 4 Daniel Berrange 2009-06-01 17:54:39 EDT
As Chris suggests the use of --location here, means it is trying to boot the HVM guest off a kernel+initrd. This definitely doesn't work in RHEL-5 Xen. What I'm not so sure of, is whether we used to handle --location differently for RHEL-5. Need to check there's no regression in --location handling from RHEL-5.3.
Comment 5 Cole Robinson 2009-06-02 09:41:40 EDT
For HVM, we used to try to fetch a boot iso via the url passed to --location. So this is a regression.
Comment 6 Daniel Berrange 2009-06-02 09:46:15 EDT
Hmm, fetching of the boot.iso from a URL is supposed to be done via the --cdrom arg, which takes a file path or a URI.
Comment 7 Cole Robinson 2009-06-02 10:37:30 EDT
Yeah, not sure if you recall John Levon mentioning this psuedo regression a while back. Sounds like an historical mistake that we need to revive for RHEL.
Comment 8 Daniel Berrange 2009-06-02 10:46:58 EDT
We have to be careful though, because HVM + --location does need to use kernel+initrd for KVM installs. So any change will need to be restricted to Xen.
Comment 9 Cole Robinson 2009-06-08 11:29:00 EDT
Fixed in python-virtinst-0.400.3-2.el5. Closing as NEXTRELEASE, since this bug has
not existed in any released package as it was brought in by the rebase.

Note You need to log in before you can comment on or make changes to this bug.