Bug 503500 - Evolution does not render certain HTML tags
Evolution does not render certain HTML tags
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-01 08:56 EDT by Christopher A. Williams
Modified: 2009-06-02 12:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-02 12:14:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test HTML File (9.24 KB, text/html)
2009-06-01 08:59 EDT, Christopher A. Williams
no flags Details

  None (edit)
Description Christopher A. Williams 2009-06-01 08:56:23 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1.Launch Evolution
2.Open received e-mail with HTML characters
  
Actual results: Characters render incorrectly. See description that follows:
A snippet of the source HTML from an e-mail example looks like this:

Some people tend to like their spirituality quick and easy. After all, there&#146;s work to do, places to go, people to see. Holiness? I&#146;ll listen to a podcast while I exercise. Servanthood? Our Sunday school class is doing a DVD series on that. Bible study? <i>The One-Minute Bible</i>&#151;and yes, there really is such a thing&#151;is a lifesaver. Patience? Who&#146;s got time for that? 
        
Evolution does not properly render certain characters in this HTML message. It displays the above source as follows:

Some people tend to like their spirituality quick and easy. After all, there’s work to do, places to go, people to see. Holiness? I’ll listen to a podcast while I exercise. Servanthood? Our Sunday school class is doing a DVD series on that. Bible study? The One-Minute Bible—and yes, there really is such a thing—is a lifesaver. Patience? Who’s got time for that?
        
I took the entire source HTML from this e-mail message, saved it off as a separate file (attached), and then tried loading it into Firefox. Firefox renders it properly! It looks like this:

Some people tend to like their spirituality quick and easy. After all, there’s work to do, places to go, people to see. Holiness? I’ll listen to a podcast while I exercise. Servanthood? Our Sunday school class is doing a DVD series on that. Bible study? The One-Minute Bible—and yes, there really is such a thing—is a lifesaver. Patience? Who’s got time for that?

Expected results: Characters should render correctly


Additional info: Attached a sample HTML file that renders correctly in Firefox, but not in Evolution.
Comment 1 Christopher A. Williams 2009-06-01 08:59:57 EDT
Created attachment 346078 [details]
Test HTML File

Test HTML source file, copied from e-mail, I used to produce the results described in this bugzilla report.
Comment 2 Matthew Barnes 2009-06-02 12:14:30 EDT
Forwarding this upstream as a GtkHTML bug.  Please see [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=584627

Note You need to log in before you can comment on or make changes to this bug.