Bug 503517 - Using "back" button in browser causes failure of CA cert password check in proxy installation
Using "back" button in browser causes failure of CA cert password check in pr...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
520
All Linux
low Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-01 10:47 EDT by Erik M Jacobs
Modified: 2009-06-02 11:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-02 08:53:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik M Jacobs 2009-06-01 10:47:46 EDT
Description of problem:
When performing a proxy installation, and using the wrong CA certificate password, pressing the "back" button in the browser at the error screen and then re-entering the password in the form allows the proxy installation to proceed.  At the last step, the operator is returned to the system details page for the desired proxy system, and the installation does not begin.

Version-Release number of selected component (if applicable):
Satellite 5.2

How reproducible:
100%

Steps to Reproduce:
1. Begin a proxy installation for a system that is correctly configured to be a proxy, checking the box(es) for SSL-enabled proxy.
2. At the CA cert credentials screen, enter the wrong certificate password.
3. At the next screen, which will be the "wrong password" error screen, press the "back" button in the browser and then re-enter the (same) wrong certificate password.
  
Actual results:
The next page is the next logical page in the installation, as if you had entered the right password the second time, even if the password entered was wrong (again).

Expected results:
The same wrong password error page should be presented to the user.

Additional info:
An "easy" fix would be to have a large warning that says "do not use your back button."  A more complicated fix would involve fixing the form(s) so that the back button doesn't cause unintended results.
Comment 1 Clifford Perry 2009-06-02 08:53:02 EDT
Proxy WebUI installer is deprecated in 5.3 release in favor of the command line installer. Proxy WebUI installer will no longer be available in future releases, post 5.3 release. I see this as a bug we plan not to fix in the future.

Cliff

Note You need to log in before you can comment on or make changes to this bug.