Bug 503587 - reposync not downloading repodata (just downloads RPMs) for trivial repo
reposync not downloading repodata (just downloads RPMs) for trivial repo
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-01 15:31 EDT by Michael DeHaan
Modified: 2014-01-21 18:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-08 14:36:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael DeHaan 2009-06-01 15:31:16 EDT
Steps to Reproduce:
1.   mkdir /var/www/html/foo
2.   cp bar.rpm into foo
3.   createrepo /var/www/html/foo
4.   Run reposync

In my case, the actual command I used was:

/usr/bin/reposync -l -m -d --config=/var/www/cobbler/repo_mirror/test/.origin/test.repo --repoid=test --download_path=/var/www/cobbler/repo_mirror
/var/www/cobbler/repo_mirror/test/.origin

[mdehaan@mdehaan html]$ cat /var/www/cobbler/repo_mirror/test/.origin/test.repo 
[test]
name=test
baseurl=http://127.0.0.1/foo
enabled=1
priority=99
gpgcheck=0

The repo looks like:

#
[mdehaan@mdehaan html]$ tree /var/www/html/foo
/var/www/html/foo
|-- python-cheetah-2.2.0-1.fc10.i386.rpm
`-- repodata
   |-- filelists.xml.gz
    |-- other.xml.gz
    |-- primary.xml.gz
    `-- repomd.xml
  

The mirrored content from reposync is:

[mdehaan@mdehaan html]$ tree /var/www/cobbler/repo_mirror/test
/var/www/cobbler/repo_mirror/test
|-- config.repo (this came from cobbler, so disregard this one file)
`-- python-cheetah-2.2.0-1.fc10.i386.rpm


The output from the reposync command is:

[mdehaan@mdehaan html]$ sudo /usr/bin/reposync -l -m -d --config=/var/www/cobbler/repo_mirror/test/.origin/test.repo --repoid=test --download_path=/var/www/cobbler/repo_mirror
Unable to fetch metadata: requested datatype group not available
[test: 1     of 1     ] Skipping existing python-cheetah-2.2.0-1.fc10.i386.rpm


Actual results:

reposync only mirrored the rpm file itself, and did not create repodata on the remote end

Expected results:

reposync mirrors the xml files

Additional info:

We seem to think this is because the original source repo never had any group content.   Reposync should be mirroring the repo whether or not it has group content (because users often don't know anything about groups)

Removal of the -m from the command does not fix the problem.
Comment 1 seth vidal 2009-07-08 14:36:44 EDT
okay - so the case where a missing comps.xml is now fixed - it won't skip the rest. But keep in mind that --download-metadata won't get the primary/filelists/other metadata b/c that information is path-specific and may not match up with how the files were just downloaded. Reposync intentionally skips those metadata files.

http://yum.baseurl.org/gitweb?p=yum-utils.git;a=commitdiff;h=6c5730dfa8e04d3af097d776d60261d818d3e442
Comment 2 Fedora Update System 2009-09-02 08:44:23 EDT
yum-utils-1.1.23-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/yum-utils-1.1.23-1.fc10
Comment 3 Fedora Update System 2009-09-02 08:44:37 EDT
yum-utils-1.1.23-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/yum-utils-1.1.23-1.fc11
Comment 4 Fedora Update System 2009-10-08 23:36:35 EDT
yum-utils-1.1.23-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.