Bug 503613 - rhnreg_ks on Fedora 10 errors during sendHardware
rhnreg_ks on Fedora 10 errors during sendHardware
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
0.5
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks: space08
  Show dependency treegraph
 
Reported: 2009-06-01 17:47 EDT by Mike Hanby
Modified: 2010-02-16 08:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-27 16:44:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Hanby 2009-06-01 17:47:41 EDT
Description of problem:
I've installed two Fedora 10 i386 workstations with Spacewalk from http://spacewalk.redhat.com/yum/0.5/Fedora/10/i386/os/ and attempted to register the clients with my spacewalk server, both fail to complete rhnreg_ks without error:

{{{
rhnreg_ks --serverUrl=http://spacewalk.mydom/XMLRPC --activationkey=1-14e821a71cdd3dccd9e9392eaa7da94b
An error has occurred:
<type 'exceptions.AttributeError'>
See /var/log/up2date for more information

}}}

The up2date log file contains:
{{{
[Mon Jun  1 15:52:10 2009] up2date 
Traceback (most recent call last):
  File "/usr/sbin/rhnreg_ks", line 266, in <module>
    cli.run()
  File "/usr/share/rhn/up2date_client/rhncli.py", line 65, in run
    sys.exit(self.main() or 0)
  File "/usr/sbin/rhnreg_ks", line 157, in main
    rhnreg.sendHardware(systemId, hardwareList)
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 645, in sendHardware
    s.registration.add_hw_profile(systemId, hardwareList)
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 50, in __call__
    return rpcServer.doCall(method, *args, **kwargs)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 194, in doCall
    ret = method(*args, **kwargs)
  File "/usr/lib/python2.5/xmlrpclib.py", line 1150, in __call__
    return self.__send(self.__name, args)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 38, in _request1
    ret = self._request(methodname, params)
  File "/usr/lib/python2.5/site-packages/rhn/rpclib.py", line 319, in _request
    request = self._req_body(params, methodname)
  File "/usr/lib/python2.5/site-packages/rhn/rpclib.py", line 222, in _req_body
    return xmlrpclib.dumps(params, methodname, encoding=self._encoding)
  File "/usr/lib/python2.5/xmlrpclib.py", line 1083, in dumps
    data = m.dumps(params)
  File "/usr/lib/python2.5/xmlrpclib.py", line 623, in dumps
    dump(v, write)
  File "/usr/lib/python2.5/xmlrpclib.py", line 638, in __dump
    f(self, value, write)
  File "/usr/lib/python2.5/xmlrpclib.py", line 698, in dump_array
    dump(v, write)
  File "/usr/lib/python2.5/xmlrpclib.py", line 638, in __dump
    f(self, value, write)
  File "/usr/lib/python2.5/xmlrpclib.py", line 719, in dump_struct
    dump(v, write)
  File "/usr/lib/python2.5/xmlrpclib.py", line 634, in __dump
    self.dump_instance(value, write)
  File "/usr/lib/python2.5/xmlrpclib.py", line 753, in dump_instance
    self.dump_struct(value.__dict__, write)
<type 'exceptions.AttributeError'>: 'dbus.String' object has no attribute '__dict__'

}}}

A partial entry for the workstation will get created on the spacewalk server, devoid of any hardware information. If I run the command again, the same error results AND another entry gets created on the spacewalk server.

I initially ran the command 3 times before I checked the web interface, 3 failures and 3 entries for the same workstation.

Version-Release number of selected component (if applicable):
Packages on the F10 clients:
 * rhnsd-4.5.9-1.fc10.i386
 * rhn-client-tools-0.4.24-1.fc10.noarch
 * yum-rhn-plugin-0.5.4-1.fc10.noarch
 * rhnlib-2.5.10-1.fc10.noarch
 * rhn-setup-0.4.24-1.fc10.noarch
 * rhn-check-0.4.24-1.fc10.noarch

How reproducible:
Happens every time on my two F10 i386 workstations.

Steps to Reproduce:
1. Create the spacewalk.repo file using http://spacewalk.redhat.com/yum/0.5/Fedora/10/i386/os/

2. yum install rhn-setup yum-rhn-plugin

3. rhnreg_ks --serverUrl=http://spacewalk.mydom/XMLRPC --activationkey=1-14e821a71cdd3dccd9e9392eaa7da94b
  
Actual results:
Errors and creates a partial record on the spacewalk server

Expected results:
Successfully create a complete record on the spacewalk server, or nothing at all producing an error code.

Additional info:
I've registered CentOS5 i386 and x86_64 workstations to this server successfully. So far, only my Fedora 10 clients exhibit this behavior. The rhn-setup versions differ from F10 and EL5:

Fedora 10 clients:
rhn-setup-0.4.24-1.fc10.noarch

EL5 clients are using version:
rhn-setup-0.4.17-8.el5
Comment 1 Mike Hanby 2009-12-02 14:49:09 EST
I have upgraded the server to 0.6 and reinstalled one of these workstations as Fedora 12 x86_64 and installed the spacewalk related rpms directly from the Fedora repositories. This time the full hardware record is added to the spacewalk server.
Comment 2 Michael Mráka 2010-01-27 16:44:51 EST
Fedora 10 is no more supported in Spacewalk 0.7 and as per comment #1 hardware info works on newer Fedora.
Closing now. Feel free to reopen if you disagree.
Comment 3 Michael Mráka 2010-02-16 08:00:03 EST
Spacewalk 0.8 has been released

Note You need to log in before you can comment on or make changes to this bug.