Bug 503671 - gnome-power-manager triggers shutdown while second battery is still on 100%
gnome-power-manager triggers shutdown while second battery is still on 100%
Status: CLOSED DUPLICATE of bug 511411
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-02 01:20 EDT by Peter Bieringer
Modified: 2009-07-28 07:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-28 07:03:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2009-06-02 01:20:56 EDT
Description of problem:
Happen on a Dell Lattitude D620 laptop with a second battery. gnome-power-manager triggers shutdown in case of the second battery runs empty while second battery is still on 100%.

Version-Release number of selected component (if applicable):
F11 version, laptop is currently powered off...

How reproducible:
At least one time

Steps to Reproduce:
1. Put in second battery
2. Let laptop run
  
Actual results:
Both batteries are recognized, the internal one keeps 100% while the second one is used. In case this battery runs out of power, an automatic shutdown is triggered.


Expected results:
Trigger of automatic shutdown only in case of both batteries are running empty.

Additional info:
Comment 1 Richard Hughes 2009-06-02 04:02:19 EDT
Have you tried the DeviceKit-power and gnome-power-manager in updates testing? Thanks.
Comment 2 Peter Bieringer 2009-06-05 01:47:48 EDT
Hmm, looks like I have already the latest ones, neither --enablerepo updates-testing nor --enablerepo rawhide shows me newer packages

# grep power /var/log/yum.log 
May 25 22:04:16 Installed: DeviceKit-power-008-0.1.20090401git.fc11.i586
May 25 22:05:01 Updated: gnome-power-manager-2.26.1-3.fc11.i586

# rpm -qa |grep power
DeviceKit-power-008-0.1.20090401git.fc11.i586
gnome-power-manager-2.26.1-3.fc11.i586
Comment 3 Bug Zapper 2009-06-09 12:57:36 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Peter Bieringer 2009-06-11 14:04:05 EDT
Looks like versions from updates-testing fix this problem: 

DeviceKit-power-008-1.fc11.i586
gnome-power-manager-2.26.2-1.fc11.i586

But still a strange message was displayed according to that the system runs out of battery, some minutes later gnome-power-manager recognized, that the second battery is now used. Perhaps this can be improved somehow, e.g. displaying 2 battery symbol (or one symbol containing 2 batteries).
Comment 5 Radek Vokal 2009-07-15 16:39:06 EDT
I'm seeing this two on my Dell D620 laptop. What's even worse - if one battery is out of juice, even if the laptop is on AC power, after login g-p-m reports that the battery is low and turns off the machine .. but I'm on AC!
Comment 6 Richard Hughes 2009-07-28 07:03:54 EDT

*** This bug has been marked as a duplicate of bug 511411 ***

Note You need to log in before you can comment on or make changes to this bug.