Bug 503707 - Plugins should require gstreamer with fully versioned dep
Summary: Plugins should require gstreamer with fully versioned dep
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-base
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 503683 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-06-02 11:09 UTC by Christoph Wickert
Modified: 2009-10-05 16:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-05 16:35:13 UTC


Attachments (Terms of Use)

Description Christoph Wickert 2009-06-02 11:09:08 UTC
Description of problem:
Currently it is possible to update gstreamer without updating the plugins. This will break and cause bug reports like bug # 503683

Version-Release number of selected component (if applicable):
gstreamer-plugins-base-0.10.23-1.fc11

How reproducible:
always

Steps to Reproduce:
1. Update gstreamer to gstreamer-0.10.23-1.fc11 but do not update gstreamer-plugins-base.
2. run something that uses gstreamer
  
Actual results:
/usr/lib/python2.6/site-packages/gst-0.10/gst/interfaces.so: undefined symbol:
gst_navigation_command_get_type

Expected results:
Plugins should also be updated

Additional info:
Currently gstreamer-plugins-base.spec looks like this:

%define         gstreamer       gstreamer
%define         majorminor      0.10

%define         _gst            0.10.22

Name:           %{gstreamer}-plugins-base
Version:        0.10.23
...

Requires:       %{gstreamer} >= %{_gst}

I think you should 

Requires:       %{gstreamer} >= %{_gst}

Or would this cause even more problems?

BTW. Use %global instead of %define, see 
https://fedoraproject.org/wiki/PackagingDrafts/global_preferred_over_define

Comment 1 Christoph Wickert 2009-06-02 11:13:20 UTC
*** Bug 503683 has been marked as a duplicate of this bug. ***

Comment 2 Bug Zapper 2009-06-09 16:58:28 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Bastien Nocera 2009-10-05 16:35:13 UTC
Fixed in rawhide by removing the separate _gst macro (which nobody ever updated).

Given that gstreamer and gstreamer-plugins-base are released at the same time, I changed this to require a gstreamer of the same version as the one we're compiling.


Note You need to log in before you can comment on or make changes to this bug.