Bug 503712 - libvirtd does not listen by default to IPv6
libvirtd does not listen by default to IPv6
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-02 07:28 EDT by Bernie Innocenti
Modified: 2010-03-16 13:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-26 10:15:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernie Innocenti 2009-06-02 07:28:20 EDT
Description of problem:
In order to get libvirtd to listen on IPv6, you have to manually
set 'listen_addr = "::"' in /etc/libvirt/libvirtd.conf.  By default,
it listens only on 0.0.0.0 (IPv4).

Version-Release number of selected component (if applicable):
libvirt-0.6.2-11.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
netstat -A inet6 -lnp | grep libvirtd
  
Actual results:
no output

Expected results:
tcp        0      0 :::16509                    :::*                        LISTEN      23321/libvirtd      
tcp        0      0 :::16514                    :::*                        LISTEN      23321/libvirtd      


Additional info:
Comment 1 Daniel Berrange 2009-06-02 07:52:58 EDT
Looks like getaddrinfo() is returning the IPv4 address before the IPv6 address, and since Linux defaults to net.ipv6.bindv6only=0, when libvirtd tries to listen on the IPv6 address  it fails with EADDRINUSE.  I really don't know why it isn't returning the IPv6 address first during the lookup.
Comment 2 Daniel Berrange 2009-06-02 08:00:33 EDT
Data point: Works correctly on RHEL-5. Fails on Fedora 9 & 11
Comment 3 Daniel Berrange 2009-11-13 06:20:36 EST
Fix pushed upstream

http://www.redhat.com/archives/libvir-list/2009-November/msg00386.html
Comment 4 Daniel Berrange 2009-11-26 10:15:23 EST
Fixed in 0.7.4 release

Note You need to log in before you can comment on or make changes to this bug.