Bug 503755 - Modesetting in F11-Preview with Mobility Radeon X700: black screen
Modesetting in F11-Preview with Mobility Radeon X700: black screen
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-02 10:43 EDT by Ken Lewis
Modified: 2009-09-08 13:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-08 13:52:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log with nomodeset option (46.55 KB, text/plain)
2009-06-02 10:43 EDT, Ken Lewis
no flags Details
output of /var/log/messages with nomodeset option (120.76 KB, text/plain)
2009-06-02 10:44 EDT, Ken Lewis
no flags Details
lspci -vvv output (11.52 KB, text/plain)
2009-06-02 10:48 EDT, Ken Lewis
no flags Details
/var/log/messages with modeset option (58.36 KB, text/plain)
2009-06-03 06:34 EDT, Ken Lewis
no flags Details
Xorg.0.log with modeset option and external screen attached (49.69 KB, text/plain)
2009-06-03 06:37 EDT, Ken Lewis
no flags Details

  None (edit)
Description Ken Lewis 2009-06-02 10:43:17 EDT
Created attachment 346264 [details]
Xorg.0.log with nomodeset option

Description of problem:
Running the F11-Preview-KDE-LiveCD on x86-64 results in a blank screen and no video output.  Starting with the 'nomodeset' kernel option gets to the KDE desktop.

Version-Release number of selected component (if applicable):
F11-Preview version

How reproducible:
Every time.

Steps to Reproduce:
1. Boot from Live CD
2. Screen Goes blank
3. Caps Lock still works
  
Actual results:
Unable to determine if computer is crashed, because screen is blank and no pointer or desktop is displayed.

Expected results:
KMS-powered beautiful startup screen and KDE4 desktop.

Additional info:
Laptop is a MSI Megabook M635 (or MS-1029) with Turion 64 processor, ATI Radeon Xpress 200 chipset and SB400 southbridge, running a Mobility Radeon X700 card on a LVDS-attached 1280x800 panel.

Will try to attach a /var/log/messages and Xorg.0.log from modeset running (using either a second monitor on VGA or SSH in from another system).
Comment 1 Ken Lewis 2009-06-02 10:44:23 EDT
Created attachment 346266 [details]
output of /var/log/messages with nomodeset option
Comment 2 Ken Lewis 2009-06-02 10:48:57 EDT
Created attachment 346268 [details]
lspci -vvv output
Comment 3 Ken Lewis 2009-06-03 06:34:15 EDT
Created attachment 346374 [details]
/var/log/messages with modeset option
Comment 4 Ken Lewis 2009-06-03 06:37:23 EDT
Created attachment 346375 [details]
Xorg.0.log with modeset option and external screen attached

/var/log/messages and Xorg.0.log with modeset enabled are the product of attaching an external monitor and watching the boot-up.  I will see what happens after I let it boot without an external screen and then add one later.
Comment 5 Bug Zapper 2009-06-09 12:58:57 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Vedran Miletić 2009-09-06 05:14:27 EDT
Reporter, please retry lastest rawhide (Fedora 12 Snap1).
Comment 7 Ken Lewis 2009-09-06 07:39:57 EDT
I reported this upstream and had it resolved with Alex Deuchar in mid-July.  If you've synced from kernel.org since then this issue is resolved.  I'm willing to try a F12 Snap1 image but I've recently become busy and can't guarantee I'll do that in the next month.

Thanks for looking over this bug again.
Comment 8 bernard.godard 2009-09-08 12:53:40 EDT
I have the same hardware. KMS works with latest rawhide. I had a black screen with F11.
Comment 9 Vedran Miletić 2009-09-08 13:52:55 EDT
Then I guess we can close this. Hopefully nothing will break until F12 gets released ;-)

Note You need to log in before you can comment on or make changes to this bug.