Bug 503787 - acpid init script fails to start during boot; "can't open /proc/acpi/event"
acpid init script fails to start during boot; "can't open /proc/acpi/event"
Status: CLOSED DUPLICATE of bug 503177
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: acpid (Show other bugs)
All Linux
medium Severity high
: rc
: ---
Assigned To: Zdenek Prikryl
: Desktop, Regression
Depends On:
  Show dependency treegraph
Reported: 2009-06-02 13:59 EDT by Suzanne Hillman
Modified: 2009-06-03 03:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-06-03 03:08:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2009-06-02 13:59:17 EDT
Description of problem:
Init script for acpid fails to start during boot, as well as if run by hand, with the error: "acpid: can't open /proc/acpi/event: Device or resource busy"

Version-Release number of selected component (if applicable):

How reproducible:
Always, at least on this machine

Steps to Reproduce:
1. Run "service acpid start"
Actual results:
Error as per above.

Expected results:
No error. Should just work like it used to.

Additional info:
Regression. At least, I've never seen this happen on boot before.
Comment 1 Zdenek Prikryl 2009-06-03 02:51:35 EDT
The problem is that hal starts earlier then acpid. So, when the pc runs, stop hal, restart acpid and start hal.

$ service haldaemon stop
$ service acpid restart
$ service haldaemon start
Comment 2 Radek Vokal 2009-06-03 03:08:30 EDT

*** This bug has been marked as a duplicate of bug 503177 ***

Note You need to log in before you can comment on or make changes to this bug.