Bug 503828 - Bluetooth can connect to mouse, but not to phones
Bluetooth can connect to mouse, but not to phones
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-02 17:58 EDT by Benjamin Kingston
Modified: 2009-06-05 08:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-05 08:17:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Kingston 2009-06-02 17:58:18 EDT
This is my first bug report, so hopefully I filed it under the correct program

Description of problem:
Pairing works just fine, but after clicking connect in "bluetooth properties" or using hcitools, the connection lasts for less than a second see additional information for my troubleshooting. Making my computer discoverable and connecting the phone to the computer has similar results.

Version-Release number of selected component (if applicable):
latest from rawhide

How reproducible:
completely

Steps to Reproduce:
1. Pair Device
2. Connect via "bluetooth properties" or hcitools
3. quickly issue clock command to device
4. observe result
5. issue clock command again
6. observe result
  
Actual results:
Disconnects almost immediately

Expected results:
Maintain connection

Additional info:

Tested 3 different phones and 2 different USB bluetooth adapters

Bluetooth mouse pairs and connects just fine.

Troubleshooting:

[root@benlaptop0 ~]# hciconfig hci0 reset
[root@benlaptop0 ~]# sudo hidd --search
Searching ...
[root@benlaptop0 ~]# sudo hcitool scan
Scanning ...
	00:22:A5:AB:27:15	benphone
You have new mail in /var/spool/mail/root
[root@benlaptop0 ~]# sudo hidd --connect 00:22:A5:AB:27:15
Can't get device information: Success

[root@benlaptop0 ~]# hcitool info 00:22:A5:AB:27:15
Requesting information ...
	BD Address:  00:22:A5:AB:27:15
	OUI Company: Texas Instruments (00-22-A5)
	Device Name: benphone
	LMP Version: 2.1 (0x4) LMP Subversion: 0x15b5
	Manufacturer: Texas Instruments Inc. (13)
	Features page 0: 0xff 0xff 0x2d 0xfe 0x9b 0xff 0x79 0x83
		<3-slot packets> <5-slot packets> <encryption> <slot offset> 
		<timing accuracy> <role switch> <hold mode> <sniff mode> 
		<park state> <RSSI> <channel quality> <SCO link> <HV2 packets> 
		<HV3 packets> <u-law log> <A-law log> <CVSD> <power control> 
		<transparent SCO> <EDR ACL 2 Mbps> <EDR ACL 3 Mbps> 
		<enhanced iscan> <interlaced iscan> <interlaced pscan> 
		<inquiry with RSSI> <extended SCO> <EV4 packets> <EV5 packets> 
		<AFH cap. slave> <AFH class. slave> <3-slot EDR ACL> 
		<5-slot EDR ACL> <sniff subrating> <pause encryption> 
		<AFH cap. master> <AFH class. master> <EDR eSCO 2 Mbps> 
		<EDR eSCO 3 Mbps> <3-slot EDR eSCO> <extended inquiry> 
		<simple pairing> <encapsulated PDU> <err. data report> 
		<non-flush flag> <LSTO> <inquiry TX power> <extended features> 
	Features page 1: 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00

If I use hcitools, I can connect, check a stat, but less than a seccond later, it disconnects

[root@benlaptop0 ~]# hcitool cc 00:22:A5:AB:27:15
[root@benlaptop0 ~]# hcitool lq 00:22:A5:AB:27:15
Link quality: 255
[root@benlaptop0 ~]# hcitool clock 00:22:A5:AB:27:15
Not connected.
Comment 1 Bastien Nocera 2009-06-04 11:46:21 EDT
Wrong component :)

What did you expect the "connect" button to do for your phone? We only list devices (or should only list devices) that have either input support, or audio support. Your device might be wrongly listed as an audio device.

Which version of bluez are you using?
Comment 2 Benjamin Kingston 2009-06-04 12:26:58 EDT
I don't remember if it was with Fedora 10, or early rawhide, but the 2nd phone I tried would connect, and then it's shares would appear in nautilus as "benphone", like a Flash drive or SDcard.

I could open it and delete/create files-folders. I vaguely remember the address being something like obex://FF:FF:FF:FF:FF (FF:FF... is the mac address of the phone)

In fact, I'm pretty sure it was F10.

I'm using bluez 4.37-2. Could you move this to where it should be?
Comment 3 Benjamin Kingston 2009-06-04 12:33:32 EDT
Edit: Just to clear up about the 2nd phone I tried:

It was the only phone I had back then, and it worked off the bat (in F10). In my tests, I have a new phone, and tried that first, then my old one (that worked in F10), which also dose not work now (in rawhide). I also tested a friends phone.

My old phone was a plain LG VX960 (or something like that)

Both my new phone and friend's phone are WinMo 6.1-6.0 (I've even tried a 6.5 rom which didn't help either)
Comment 4 Bastien Nocera 2009-06-04 18:53:58 EDT
"Connect" does not browse files. "Browse files" does. Connect connects to the input or audio device.

Which version of gnome-bluetooth do you have?
Comment 5 Benjamin Kingston 2009-06-04 22:39:45 EDT
2.27.5, Sorry I thought it was still in bluez.

There is not an option for "browse files" when any of the 3 phones were paired.
Comment 6 Bastien Nocera 2009-06-05 04:42:44 EDT
nautilus needs to be installed for browse files to be available. See the second picture on http://live.gnome.org/GnomeBluetooth for what it looks like.
Comment 7 Benjamin Kingston 2009-06-05 06:13:53 EDT
I can't believe that it was staring me in the face all this time...doh.

Well now that that's cleared up, i'm still curious why hcitools wouldn't stay connected for longer than a second. But maybe that's an issue for the forums?

You can close this if you want.
Comment 8 Bastien Nocera 2009-06-05 08:17:06 EDT
Why would hcitool keep the connection alive? There's no services running on top of it. There's no reasons for it to be kept alive.

Note You need to log in before you can comment on or make changes to this bug.