Bug 503845 - Traceback on FC11 prerelease install
Traceback on FC11 prerelease install
Status: CLOSED DUPLICATE of bug 496341
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
anaconda_trace_hash:aa3b8ab66c8456444...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-02 20:29 EDT by Jonathan McDowell
Modified: 2009-06-12 09:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-12 09:28:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (102.87 KB, text/plain)
2009-06-02 20:29 EDT, Jonathan McDowell
no flags Details

  None (edit)
Description Jonathan McDowell 2009-06-02 20:29:24 EDT
The following was filed automatically by anaconda:
anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 49, in __init__
    self.__disk = _ped.Disk(device.getPedDevice())
  File "/usr/lib/anaconda/storage/devices.py", line 703, in __init__
    self.partedDisk = parted.Disk(device=self.partedDevice)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1087, in addUdevDiskDevice
    initcb=cb, initlabel=initlabel, **kwargs)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1160, in addUdevDevice
    device = self.addUdevDiskDevice(info)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1627, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 288, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 72, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1330, in nextClicked
    self.anaconda.dispatch.gotoNext()
NotImplementedError: Partition 3 isn't aligned to cylinder boundaries.  This is still unsupported.
Comment 1 Jonathan McDowell 2009-06-02 20:29:31 EDT
Created attachment 346336 [details]
Attached traceback automatically from anaconda.
Comment 2 Joel Andres Granados 2009-06-03 05:54:18 EDT
This is parted being a pain in the but.  The plan is to change parted's behavior and introduce it to the new millennium by teaching it that you no longer have to align to cylinder sizes.
This is planned for f12.
Comment 3 Bug Zapper 2009-06-09 13:00:03 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Joel Andres Granados 2009-06-12 09:28:03 EDT

*** This bug has been marked as a duplicate of bug 496341 ***

Note You need to log in before you can comment on or make changes to this bug.