Bug 503865 - Customized Search -- 'Body Contains' is not correct [NEEDINFO]
Customized Search -- 'Body Contains' is not correct
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-03 00:53 EDT by zhanghaiyan
Modified: 2014-06-03 08:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:49:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (yoyzhang)


Attachments (Terms of Use)

  None (edit)
Description zhanghaiyan 2009-06-03 00:53:31 EDT
Description of problem:
Customized search 'Body Contains', mails are listed out whose title contains while body doesn't contain.

Version-Release number of selected component (if applicable):
Arch: RHEL5.4-Server-x86_64
      RHEL5.4-Client-i386
Version:
     evolution-2.12.3-17.el5
     evolution-data-server-1.12.3-17.el5
     evolution-connector-2.12.3-9.el5
  
How reproducible:
Always

Steps to Reproduce:
   1. Launch Evolution
   2. Click the search icon in the search bar to specify the search type.
   3. Select Body Contains
   4. Type the search string in the search entry and press Enter
  
Actual results:
  It also searches in mail title, and listed mails whose title have searched string.

Expected results:
   Verify that it searches only in body text, not any other header

Additional info:
Comment 1 zhanghaiyan 2009-06-03 01:04:27 EDT
Also reproduce on evolution-2.12.3-17.el5

Modify actual result: 
  It also searches in other header, such as Subject and Sender
Comment 2 zhanghaiyan 2009-06-03 01:04:44 EDT
Also reproduce on evolution-2.12.3-18.el5
Comment 3 liuqian 2009-06-05 06:24:40 EDT
Also reproduced on RHEL5.4-Server-ia64
                   RHEL5.4-Server-ppc
on evolution-2.12.3-17.el5
Comment 4 RHEL Product and Program Management 2014-03-07 07:47:59 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 5 RHEL Product and Program Management 2014-06-03 08:49:00 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.