Bug 503870 - (traceback) Traceback while updating
Traceback while updating
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-03 01:45 EDT by Luya Tshimbalanga
Modified: 2009-06-07 08:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-07 08:10:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luya Tshimbalanga 2009-06-03 01:45:59 EDT
Description of problem:
Traceback happened with simple update

Version-Release number of selected component (if applicable):

2.27.2

How reproducible:


Steps to Reproduce:
1. Just do a normal update
2.
3.
  
Actual results:

Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 1830, in _runYumTransaction
    rpmDisplay=rpmDisplay)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 3609, in processTransaction
    pkgs = self._downloadPackages(callback)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 3633, in _downloadPackages
    probs = self.downloadPkgs(dlpkgs)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 1313, in downloadPkgs
    self.plugins.run('predownload', pkglist=pkglist)
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 180, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/presto.py", line 577, in predownload_hook
    (problems, more) = downloadPkgs(conduit, pinfo, download_pkgs)
  File "/usr/lib/yum-plugins/presto.py", line 419, in downloadPkgs
    cb.start(text="<delta rebuild>", size=rebuild_size)
  File "/usr/lib/python2.6/site-packages/urlgrabber/progress.py", line 129, in start
    self._do_start(now)
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2551, in _do_start
    self.updateProgress(name, 0.0, "", "")
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2593, in updateProgress
    pkg = self._getPackage(name)
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2534, in _getPackage
    sections = name.rsplit('-', 2)
AttributeError: 'NoneType' object has no attribute 'rsplit'


Expected results:

PackageKit should update normally.

Additional info:
Comment 1 Richard Hughes 2009-06-03 03:52:35 EDT
What version PackageKit? Can you please try https://admin.fedoraproject.org/updates/F11/FEDORA-2009-5750
Comment 2 Luya Tshimbalanga 2009-06-03 04:14:12 EDT
Version 0.4.6-8.fc11
Comment 3 Richard Hughes 2009-06-03 04:43:08 EDT
Can you try installing https://admin.fedoraproject.org/updates/F11/FEDORA-2009-5750 and https://admin.fedoraproject.org/updates/F11/FEDORA-2009-5748 and then reboot please. If it fixes things, please report that as positive karma for the update. Thanks.
Comment 4 Luya Tshimbalanga 2009-06-05 17:05:49 EDT
FEDORA-2009-5750 update fixed the icon tray. FEDORA-2009-5750 works on Gnome desktop but, as pointed out, broke on kpackagekit. Since the bug concerns about update traceback, the issue is solved.

Note You need to log in before you can comment on or make changes to this bug.