This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 503909 - Package rubygem-rails missing dependency on rubygem-rake
Package rubygem-rails missing dependency on rubygem-rake
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rubygem-rails (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: David Lutterkort
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-03 06:27 EDT by Rob Lazzurs
Modified: 2013-04-30 19:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-27 15:01:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Lazzurs 2009-06-03 06:27:45 EDT
Description of problem:

The rubygem-rails package requires rubygem-rake >= 0.8.3 however the RPM package of rubygem-rails does not reflect this requirement.

Version-Release number of selected component (if applicable):

rubygem-rails-2.3.2-2

How reproducible:

On any system that does not have rubygem-rake >= 0.8.3 already installed

Steps to Reproduce:
1. Install rubygem-rails
2. run rails -v

  
Actual results:



[rl@midori SPECS]$ rails -v
/usr/lib/ruby/site_ruby/1.8/rubygems.rb:636:in `report_activate_error': RubyGem version error: rake(0.8.1 not >= 0.8.3) (Gem::LoadError)
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:141:in `activate'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:165:in `activate'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:164:in `each'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:164:in `activate'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:49:in `gem'
        from /usr/bin/rails:18
Comment 1 Fabian Deutsch 2009-08-20 06:56:04 EDT
This package is also missing a dependency on rubygem-sqlite3-ruby
Comment 2 Mamoru TASAKA 2010-01-27 15:01:22 EST
As current F-11 rubygem-rake is 0.8.7, this can be closed.

Note You need to log in before you can comment on or make changes to this bug.