Bug 503919 - add a xscreensaver panel button
add a xscreensaver panel button
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lxde-common (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks: LXDE
  Show dependency treegraph
 
Reported: 2009-06-03 07:29 EDT by Rahul Sundaram
Modified: 2013-03-13 01:45 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.4.1-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-13 14:39:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of lxpanel with missing launcher (30.74 KB, image/png)
2009-06-09 21:36 EDT, Christoph Wickert
no flags Details

  None (edit)
Description Rahul Sundaram 2009-06-03 07:29:20 EDT
Description of problem:

Would be nice to have a panel button for xscreensaver by default
Comment 1 Christoph Wickert 2009-06-03 07:43:07 EDT
Really bad Idea imho, because then we would have to make lxpanel depend on xscreensaver-base.
Comment 2 Rahul Sundaram 2009-06-03 07:51:03 EDT
Anything that does:

if (package installed)
   display icon
else
   nothing

That would be useful.
Comment 3 Christoph Wickert 2009-06-03 08:44:57 EDT
First of all we would need a xsreensaver desktop file. Should be provided by xscreensaver-base, not by lxpanel.

Then we need another launchbar with the starter inside. The icon will not be displayed if the desktop file is missing, but the space will be wasted by the launchbar and there will be an empty line in the configuration dialog. I guess this will get us some bog reports, I already had this a couple of times.

IMO this whole idea fundamentally conflicts with the modular approach of LXDE. LXDE does not drive people to use this or that screen saver. If you want this however as part of LXDE and not lxpanel, reassign the bug to lxde-common and maybe I will take it into account. Honestly I cannot really promise to do so, because IMO the downsides outbalance the advantage. Every default config should be sane, users can still enhance it for their needs.
Comment 4 Bug Zapper 2009-06-09 13:01:55 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Christoph Wickert 2009-06-09 21:36:59 EDT
Created attachment 347125 [details]
Screenshot of lxpanel with missing launcher

This is what will happen if the desktop file referenced in the configuration is not installed: Broken image between clock and mixer and a missing entry in the config dialog. I'm sure this is not what we want.
Comment 6 Christoph Wickert 2009-06-13 12:17:05 EDT
How about that?

Require xdg-utils and use "xdg-screensaver lock", so we are screensaver independent. Nevertheless this should not be done in lxpanel's default config  but in lxde-common, so lxpanel itself can be used/installed without screensaver. yum groupinstall LXDE already installs a xscreensaver and if screensaver is installed, we have at least the launcher instead of a broken icon, since the desktop file can be included in lxde-common.
Comment 7 Christoph Wickert 2009-06-13 14:36:12 EDT
Ok, lxde-common-0.4.1-2 has both logout and lock screen button. The logout button was already introduced in 0.4, but not installed by the Makefile.
Comment 8 Rahul Sundaram 2009-06-13 14:39:01 EDT
Thanks. That will do.
Comment 9 Fedora Update System 2009-06-13 14:39:34 EDT
lxde-common-0.4.1-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/lxde-common-0.4.1-2.fc11
Comment 10 Fedora Update System 2009-06-15 22:17:02 EDT
lxde-common-0.4.1-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.