Bug 503971 - screen corruption, noise on resize (ATI, DVI)
screen corruption, noise on resize (ATI, DVI)
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
5.4
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-03 11:27 EDT by Mark Gordon
Modified: 2013-07-28 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 16:08:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of 1600x1200 corruption, incidently including xrandr output (1.34 MB, image/png)
2009-06-03 11:27 EDT, Mark Gordon
no flags Details

  None (edit)
Description Mark Gordon 2009-06-03 11:27:28 EDT
Created attachment 346408 [details]
Screenshot of 1600x1200 corruption, incidently including xrandr output

Description of problem:
Resizing the display using gnome-display-properties produces pathological results for several resolutions when using the DVI connection.  At 1600x1200, there's a great deal of corruption which is especially visible when windows are dragged, though even initial rendering is messed up.  I'm able to capture the results in a screenshot.  At 1440x900, there's a noisy, flickering vertical band along the right edge of the screen, but it doesn't show up in a screenshot.  None of the other resolutions have any such problems, and the VGA resolutions are all fine.  This is a first look at 5.4, and I'm not sure how hardware-specific this problem is, but since the problem is limited to a few resolutions, it's clearly not completely general.

Version-Release number of selected component (if applicable):
RHEL5.4-Client-20090528.4
xorg-x11-drv-ati-6.6.3-3.25.el5
xorg-x11-server-Xorg-1.1.1-48.62.el5

How reproducible:
always

Steps to Reproduce:
1. run gnome-display-properties
2. change resolution to 1600x1200
3. change resolution to 1440x900
  
Actual results:
corruption (1600x1200), noise (1440x900)

Expected results:
Reasonably sane rendering

Additional info:
ATI FireGL 8800 AGP card
acer X223W monitor
DVI connection
Comment 2 Dave Airlie 2009-09-15 17:27:51 EDT
can you see if changing the driver from radeon to r500 in xorg.conf helps?
Comment 3 Mark Gordon 2009-09-16 15:17:43 EDT
It does.  The noise goes away.  

(For the record, the noise is slightly changed in the final radeon driver; the noise I had been seeing at 1440x900 is now also evident at 1600x1200 instead of the corruption previously seen at 1600x1200.)
Comment 6 Adam Jackson 2012-04-17 16:08:40 EDT
No further hardware enablement updates are planned for RHEL5's X stack.  If this issue remains in RHEL6, please update the affected product version and reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.