Bug 504003 - cp -r HardDrive to USB Mem. stick converts all UpperCase dir names to LowerCase
cp -r HardDrive to USB Mem. stick converts all UpperCase dir names to LowerCase
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-03 14:36 EDT by Al
Modified: 2014-01-12 19:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 15:59:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Al 2009-06-03 14:36:11 EDT
Description of problem: 

Using    cp -r      from Hard disk to USB Memory stick,
Files with all Uppercase names get converted to Lower case names.


Version-Release number of selected component (if applicable):
[faconle@pengi1 Test_cp]$ uname -a
Linux pengi1 2.6.27.23-78.2.50.fc9.i686 #1 SMP Mon May 11 11:27:07 EDT 2009 i686 athlon i386 GNU/Linux

How reproducible: easy, I think.


Steps to Reproduce:

[faconle@pengi1 ~]$ 
[faconle@pengi1 ~]$ mkdir Test_cp
[faconle@pengi1 ~]$ cd Test_cp/
[faconle@pengi1 ~/Test_cp]$ ls
[faconle@pengi1 ~/Test_cp]$ mkdir TEST1
[faconle@pengi1 ~/Test_cp]$ mkdir test2
[faconle@pengi1 ~/Test_cp]$ mkdir Test3
[faconle@pengi1 ~/Test_cp]$ 
[faconle@pengi1 ~/Test_cp]$ cd /media/disk/
[faconle@pengi1 disk]$ mkdir Test
[faconle@pengi1 disk]$ ls Test
[faconle@pengi1 disk]$ 
[faconle@pengi1 disk]$ cd
[faconle@pengi1 ~]$ cp -r ./Test_cp   /media/disk/Test/
[faconle@pengi1 ~]$ 
[faconle@pengi1 ~]$ 
[faconle@pengi1 ~]$ cd /media/disk/Test
[faconle@pengi1 Test]$ ls
Test_cp
[faconle@pengi1 Test]$ cd Test_cp
[faconle@pengi1 Test_cp]$ ls
test1  test2  Test3
[faconle@pengi1 Test_cp]$ 

  
Actual results:Directory TEST1 is translated to test1


Expected results:
Conversion of Uppercase to Lowercase should not occur.


Additional info: cp -r to hard drive file system is ok. Tried 2 diff. memory
stick types same result.  Also same result using   Copy  and Paste
with mouse.  I was using tcsh in teminal mode.
Comment 1 Will Woods 2009-06-03 14:59:48 EDT
Your memory stick is probably FAT (DOS/Windows) formatted. FAT is case-insensitive, so the differences don't mean anything.

Windows 95 converts all-capital names to lowercase; the vfat driver just follows that standard.

If your memory sticks are FAT then this is the expected behavior. You can check the output of the 'mount' command to see what filesystem the mounted stick is using.

Note You need to log in before you can comment on or make changes to this bug.