Bug 50402 - No Drives found/ no valid devices raid adaptec 2100s
No Drives found/ no valid devices raid adaptec 2100s
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-30 18:27 EDT by Steve H
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-10 13:02:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve H 2001-07-30 18:27:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Hi,

I have tried to install Red Hat 7.1 on a server with 2 pent 3 intel board 
IBM drives and adaptec 2100s raid card.  The raid is the bootable 
drive/s.  When installing in expert text mode anaconda asks me for the 
drive for any drivers.  I have the most up to date drivers for the 2100s 
from the adaptec site and it seems that anaconda installs the driver 
correctly.  After anaconda completes this part of the install it ask me 
the type of keyboard i'm using and then goes to the dialog box that has 
redhat website information.  As soon as I choose that I get "No Drives 
Found, an error has occurred - no valid devices were found on which to 
create new filesystems.  Please check your hardware for the cause of this 
problem".

Note: the drive is raided properly.
Note: I just installed FreeBSD 4.3 on the box to see if I may have a 
hardware problem but it seems not.



How reproducible:
Always

Steps to Reproduce:
1.install attempt
2.
3.
	

Actual Results:  No Drives Found

Expected Results:  installation will continue

Additional info:
Comment 1 Herbert Gasiorowski 2001-08-02 10:05:09 EDT
I think i have got nearly the same problem:
440GX board, AIC7xxx driver found (thanks to new bootnet.img from Doug)
and a kickstart installation which normaly works very well (with minor changes).

After loading the AIC7xxx the same Error occurs.
Using Alt-F2 I cannot find any /dev/sd* ...
Comment 2 Herbert Gasiorowski 2001-08-03 05:25:15 EDT
My (additional) problem is solved (440gx board, AIC7xxx driver):

I have tried to change the kernel of the install floppy AND boot image
with no success
AND then forgotten to replace the stage2.img with the original one
when using the bootnet.img with the old kernel again.
Comment 3 Brent Fox 2001-08-10 12:55:25 EDT
babo_org, have you tried the updates disk from Doug Ledford?  It can be found
at: http://www.redhat.com/support/docs/gotchas/7.1/gotchas-71.html

Does that help?  I'm changing component to the kernel since this is an Adapted
driver problem.
Comment 4 Arjan van de Ven 2001-08-10 13:01:59 EDT
Ehm it seems the adaptec driver is for Red Hat Linux 7.0.... which has a 2.2
kernel instead of a 2.4 kernel so I'm not surprised it doesn't work.
(or the adaptec website is playing silly buggers and hides the 7.1 stuff from
me)
Comment 5 Steve H 2001-08-10 17:22:53 EDT
This issue has be resolved.  I called Adaptec and they put me in a private 
download area that they had a driver for 7.1.  I'm not sure why they are not 
publishing it but everything works like a champ now.

Regards,

thanks for the feed back.

Steve Hardin

Note You need to log in before you can comment on or make changes to this bug.