Bug 504028 - Improve Documentation of Cluster Mirror Configuration in LVM Manual
Improve Documentation of Cluster Mirror Configuration in LVM Manual
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Documentation-cluster (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Steven J. Levine
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-03 16:57 EDT by Steven J. Levine
Modified: 2009-09-03 11:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 11:55:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven J. Levine 2009-06-03 16:57:26 EDT
Description of problem:

As of RHEL 5.3, cluster mirrors are supported in LVM. The documentation, however, should include more advice about general setup and configuration, and an example. With the help of Eduardo Damato, I have added this information to the RHEL 4.8 version of the document. I need to add comparable info for RHEL 5.4 (pushing it back to RHEL 5.3 if possible), updating for RHEL 5. There may also be a kbase article about how mirrors are reflected in the device mapper hierarchy, and I should check into referencing that when it is complete.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Steven J. Levine 2009-08-11 17:44:05 EDT
The info I added to 4.8 is in the draft of the 5.4 version and will be released with RHEL 5.4.
Comment 6 Steven J. Levine 2009-08-21 12:43:39 EDT
I've made all the changes indicated here -- with the exception of the following:

- Re: changing the examples so that they don't use the lock_nolock protocol --
that's actually a big task, both here and elsewhere, since when I originally
wrote this book all my examples were local. So to change that protocol I would
have to redo all of my examples either to be sure I was making everything
clustered, or to use a different file system than gfs/gfs2. For example, the vgs output in the examples would have to be changed to show the C attribute -- and I would want to run all the examples as clustered examples beginning to end, redoing all the setup and output. As I say, that's a large project.

And it gets even bigger: The entire GFS and GFS2 manuals are written with the assumption that you can use the file systems either in a cluster or locally (although why you'd use GFS locally is a question people have asked me here).

So what I'm going to do is open a separate bug for all my documentation, to say: update LVM and GFS and GFS2 documentation to account for deprecation of use of GFS/GFS2 file systems as local file systems. 

- Also: I have not yet documented the first RHEL 5 release that supports the seg_pe_ranges option, as I'm waiting to find out which RHEL 5 release that was. As soon as I get that info I'll rebuild this document on the staging area and check it in and change the status of this bug to MODIFIED.
Comment 8 Steven J. Levine 2009-09-03 11:55:27 EDT
With the release of RHEL 5.4 I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.