This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 504043 - when using boot.iso I don't have fsadm
when using boot.iso I don't have fsadm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Zdenek Kabelac
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-03 18:21 EDT by Matěj Cepl
Modified: 2013-01-10 00:14 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 02:08:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2009-06-03 18:21:01 EDT
Description of problem:
When running rescue mode from http://sunsite.mff.cuni.cz/pub/fedora/development/x86_64/os/images/boot.iso (on KVM virtual machine) I tried to run

lvm lvreduce -L -6G -r -v -t /dev/VolGroup00/LogVol00
...
Executing: fsadm --dry-run --verbose check /dev/VolGroup00/LogVol00

but apparently there is no fsadm on the disk. Which is weird, because there is lvm from the same package lvm2.

Version-Release number of selected component (if applicable):
boot.iso dated 2009-05-31

How reproducible:
100%

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
no fsadm, have to run resize2fs manually with calculating number of sectors to shrink (asking for screwing it up); FAIL -- the most important reason for me why to run Rescue Mode is to change size of root LV.

Expected results:
just works

Additional info:
Comment 1 Chris Lumens 2009-06-04 11:07:17 EDT
This will be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 2 Matěj Cepl 2009-06-04 11:34:12 EDT
Actually fsadm from F11 doesn't work in busybox (readlink doesn't have -e parameter).
Comment 3 Milan Broz 2009-06-04 11:44:42 EDT
To fix busybox or not to fix busybox (and fix fsadm instead)?
That is the question.
Comment 4 Zdenek Kabelac 2009-06-05 07:57:15 EDT
It looks like we have here couple issues - rescue image seems to only contain  'lvm' binary - so there are no symlinks for commands like lvresize, fsadm - so it looks like lvm has some 'special' installation for rescue image - I'm wondering how are dependencies solved in this case?

Should we list binaries we need for lvm to make it operational?

For now it looks like fsadm, lvresize symlink and blockdev command is missing in the rescue image.
Comment 5 Alasdair Kergon 2009-06-05 08:03:31 EDT
The script should be running 'lvm lvresize' not 'lvresize'.
Comment 6 Alasdair Kergon 2009-06-05 08:05:19 EDT
(fix the script to work the same way as lvm_dump.sh)
Comment 7 Zdenek Kabelac 2009-06-09 11:46:11 EDT
Script was updated with commit https://www.redhat.com/archives/lvm-devel/2009-June/msg00048.html - new boot.iso will be checked when it will be ready.
Comment 8 Denys Vlasenko 2009-06-12 07:20:19 EDT
busybox readlink fix is at

http://busybox.net/downloads/fixes-1.14.1/busybox-1.14.1-readlink.patch
Comment 9 Ivana Varekova 2009-06-15 02:08:49 EDT
thanks Denys - patch backported to 1.14.1-2.fc12.

Note You need to log in before you can comment on or make changes to this bug.