This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 504144 - umount sometimes keeps keys in keyring
umount sometimes keeps keys in keyring
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ecryptfs-utils (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Michal Hlavinka
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-04 09:06 EDT by Michal Nowak
Modified: 2013-03-07 21:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-03 07:47:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2009-06-04 09:06:58 EDT
Description of problem:

http://rhts.redhat.com/testlogs/62716/205783/1703592/TESTOUT.log

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Testing-NOT-Key-in-Keyring
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   PASS   ] :: Unmount all sec\* dirs
2 keys in keyring:
1019058521: --alswrv     0     0 user: 6293455a29efa397
342556671: --alswrv     0     0 user: 13e8b1bc6090e91d
:: [   FAIL   ] :: Keyring is clear (Expected 0, got 1)
1
8424257
/CoreOS/ecryptfs-utils/Regression/bz501460-correct-error-msg-when-adding-to-full-keyring/Testing-NOT-Key-in-Keyring result: FAIL

Version-Release number of selected component (if applicable):

75-5.el5.i386

How reproducible:

sometimes

Steps to Reproduce:

do ~20 times: 
   generate new SSL key
   use the new key to mount dirX
done
umount all dirs via: umount dir*/
  
Actual results:

- sometimes two keys are left in the keyring
- no error msg from umount

Expected results:

- all keys removed from keyring
Comment 1 Michal Hlavinka 2009-06-04 09:27:33 EDT
which way you mount and umount this?
Comment 2 Michal Nowak 2009-06-04 09:33:26 EDT
/sbin/mount.ecryptfs sec$keycnt/ sec$keycnt/ -o "key=openssl:openssl_keyfile=key$keycnt.pem:openssl_passwd=password,ecryptfs_cipher=des3_ede,ecryptfs_key_bytes=24,verbosity=0" &> $keycnt.out


umount sec*/

See RHTS test case: /CoreOS/ecryptfs-utils/Regression/bz501460-correct-error-msg-when-adding-to-full-keyring
Comment 3 Michal Nowak 2009-06-29 10:44:13 EDT
Is it reproducible? More info needed?
Comment 4 Michal Hlavinka 2009-07-01 02:53:02 EDT
(In reply to comment #3)
> Is it reproducible?
no, I'm not able to reproduce this at all

> More info needed?  
yes, whatever info that will help me reproduce this. How often is this reproducible for you? What platform?
Comment 5 Michal Nowak 2009-07-03 07:06:37 EDT
I don't see it happening when the test is run standalone but only when is part of test-set scheduled via RHTS web UI. The problem therefor might be that the session keyring is dirty on test start already and because of this the keyring-isClean-subtest fails.

I enhanced the test and will schedule it once more again.
Comment 6 Michal Nowak 2009-07-03 07:47:13 EDT
Ou, yee. As I said two tests were leaving keys in keyring and they should not.

Note You need to log in before you can comment on or make changes to this bug.