Bug 504170 - pulseaudio hits cpu limit and dies (intel HDA)
pulseaudio hits cpu limit and dies (intel HDA)
Status: CLOSED DUPLICATE of bug 485734
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-04 10:59 EDT by Matt Piermarini
Modified: 2009-06-11 22:21 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-11 22:21:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
listing of pulseaudio -vvv (100.67 KB, application/octet-stream)
2009-06-04 10:59 EDT, Matt Piermarini
no flags Details

  None (edit)
Description Matt Piermarini 2009-06-04 10:59:40 EDT
Created attachment 346549 [details]
listing of pulseaudio -vvv

Description of problem:

Pulseaudio keeps crashing.


Jun  4 10:42:46 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing wakeup watermark to 1965.99 ms
Jun  4 10:42:46 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing minimal latency to 1986.00 ms

..... TONS OF THESE....

Jun  4 10:42:46 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing minimal latency to 1999.82 ms
Jun  4 10:42:46 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing wakeup watermark to 1989.80 ms
Jun  4 10:42:50 mpiermar-pc pulseaudio[4501]: ratelimit.c: 2623 events suppressed
Jun  4 10:42:53 mpiermar-pc pulseaudio[4501]: cpulimit.c: Received request to terminate due to CPU overload.

To keep it alive, I have to set 
no-cpu-limit = yes
in /etc/pulse/daemon.conf

when no-cpu-limit=yes is set, I get tons of these:

pulseaudio[4434]: ratelimit.c: 2632 events suppressed

and CPU is 100%+.  Sound quality is very erratic (pauses/skipping/etc)

Version-Release number of selected component (if applicable):

Fedora 11

How reproducible:


Steps to Reproduce:
1.  Start Sound (System->preferences->sound)
2.  Click tabs (Sound Effects/Input/Output/Applications)
3.
  
Actual results:

pulseaudio[4501]: cpulimit.c: Received request to terminate due to CPU overload.

Expected results:


Additional info:

Linux mpiermar-pc 2.6.29.4-167.fc11.i686.PAE #1 SMP Wed May 27 17:28:22 EDT 2009 i686 athlon i386 GNU/Linux

lspci -v
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
	Subsystem: Foxconn International, Inc. Device 0e0f
	Flags: bus master, slow devsel, latency 64, IRQ 16
	Memory at f9ff0000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [50] Power Management version 2
	Kernel driver in use: HDA Intel
	Kernel modules: snd-hda-intel


pulseaudio -vvv (snippet .. see attachment for full)

N: alsa-source.c: Increasing minimal latency to 946.00 ms
D: alsa-source.c: latency set to 946.00ms
D: alsa-source.c: hwbuf_unused=185896
D: alsa-source.c: setting avail_min=883
I: memblock.c: Pool full
I: memblock.c: Pool full
I: memblock.c: Pool full
I: memblock.c: Pool full
... this last message forever (until CPU limit hit, or forever if no-cpu-limit set).

Entire /var/log/messages:

Jun  4 10:42:43 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun  4 10:42:43 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun  4 10:42:43 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun  4 10:42:43 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun  4 10:42:43 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=256, bytes=128, size=4096, periods=32
Jun  4 10:42:43 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun  4 10:42:43 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=384, bytes=384, size=12288, periods=32
Jun  4 10:42:43 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun  4 10:42:43 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=384, bytes=384, size=12288, periods=32
Jun  4 10:42:43 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun  4 10:42:43 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=384, bytes=384, size=12288, periods=32
Jun  4 10:42:43 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun  4 10:42:43 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=512, bytes=128, size=4096, periods=32
Jun  4 10:42:43 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun  4 10:42:43 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing minimal latency to 1.00 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing minimal latency to 2.00 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing minimal latency to 4.00 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing minimal latency to 8.00 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing minimal latency to 16.00 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing minimal latency to 26.00 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing wakeup watermark to 15.99 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing minimal latency to 36.00 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing wakeup watermark to 25.99 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing minimal latency to 46.00 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing wakeup watermark to 35.99 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing minimal latency to 56.00 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c: snd_pcm_delay() returned a value that is exceptionally large: 1480726784 bytes (8394142 ms).
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_hda_intel'. Please report this issue to the ALSA developers.
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c: snd_pcm_dump():
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c: Soft volume PCM
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c: Control: PCM Playback Volume
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c: min_dB: -51
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c: max_dB: 0
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c: resolution: 256
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c: Its setup is:
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   stream       : CAPTURE
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   access       : MMAP_INTERLEAVED
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   format       : S16_LE
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   subformat    : STD
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   channels     : 2
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   rate         : 44100
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   exact rate   : 44100 (44100/1)
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   msbits       : 16
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   buffer_size  : 88192
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   period_size  : 44096
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   period_time  : 999909
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   tstamp_mode  : ENABLE
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   period_step  : 1
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   avail_min    : 44096
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   period_event : 0
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   start_threshold  : -1
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   stop_threshold   : 1444937728
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   silence_threshold: 0
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   silence_size : 0
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   boundary     : 1444937728
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c: Slave: Hardware PCM card 1 'HDA ATI SB' device 0 subdevice 0
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c: Its setup is:
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   stream       : CAPTURE
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   access       : MMAP_INTERLEAVED
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   format       : S16_LE
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   subformat    : STD
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   channels     : 2
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   rate         : 44100
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   exact rate   : 44100 (44100/1)
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   msbits       : 16
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   buffer_size  : 88192
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   period_size  : 44096
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   period_time  : 999909
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   tstamp_mode  : ENABLE
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   period_step  : 1
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   avail_min    : 44096
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   period_event : 0
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   start_threshold  : -1
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   stop_threshold   : 1444937728
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   silence_threshold: 0
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   silence_size : 0
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   boundary     : 1444937728
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   appl_ptr     : 1014208
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c:   hw_ptr       : 0
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing wakeup watermark to 45.99 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing minimal latency to 66.00 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing wakeup watermark to 55.99 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing minimal latency to 76.00 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing wakeup watermark to 65.99 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing minimal latency to 86.00 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing wakeup watermark to 75.99 ms
Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing minimal latency to 96.00 ms

... TONS OF THESE MESSAGES SNIPPED....

Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing wakeup watermark to 85.99 ms
Jun  4 10:42:46 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing minimal latency to 1996.00 ms
Jun  4 10:42:46 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing wakeup watermark to 1985.99 ms
Jun  4 10:42:46 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing minimal latency to 1999.82 ms
Jun  4 10:42:46 mpiermar-pc pulseaudio[4501]: alsa-source.c: Increasing wakeup watermark to 1989.80 ms
Jun  4 10:42:50 mpiermar-pc pulseaudio[4501]: ratelimit.c: 2623 events suppressed
Jun  4 10:42:53 mpiermar-pc pulseaudio[4501]: cpulimit.c: Received request to terminate due to CPU overload.



pulseaudio -vvv
  see attachment.
Comment 1 Will Woods 2009-06-04 11:10:41 EDT
> Jun  4 10:42:45 mpiermar-pc pulseaudio[4501]: alsa-util.c: Most likely this is
a bug in the ALSA driver 'snd_hda_intel'. Please report this issue to the ALSA
developers.

As the message says - this is caused by a bug in the ALSA driver. Reassigning to kernel.
Comment 2 Matt Piermarini 2009-06-11 22:21:53 EDT
Note, 

I just noticed bug 485734, which this seems to a duplicate of.  I added
options snd_hda_intel position_fix=1, and it works *MUCH* better.  Pulse no longer takes 100% of cpu and does not crash anymore. Get these new messages, but it does work.


Jun 11 22:11:32 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun 11 22:11:32 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun 11 22:11:32 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun 11 22:11:32 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun 11 22:11:32 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=256, bytes=128, size=4096, periods=32
Jun 11 22:11:32 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun 11 22:11:32 mpiermar-pc kernel: fuse init (API version 7.11)
Jun 11 22:11:32 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=384, bytes=384, size=12288, periods=32
Jun 11 22:11:32 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun 11 22:11:32 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=384, bytes=384, size=12288, periods=32
Jun 11 22:11:32 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun 11 22:11:32 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=384, bytes=384, size=12288, periods=32
Jun 11 22:11:32 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun 11 22:11:32 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=512, bytes=128, size=4096, periods=32
Jun 11 22:11:32 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun 11 22:11:32 mpiermar-pc kernel: ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
Jun 11 22:11:32 mpiermar-pc pulseaudio[2798]: pid.c: Daemon already running.
Jun 11 22:11:33 mpiermar-pc kernel: JBD: barrier-based sync failed on dm-4:8 - disabling barriers
Jun 11 22:11:33 mpiermar-pc pulseaudio[2845]: pid.c: Daemon already running.
Jun 11 22:11:37 mpiermar-pc gnome-keyring-daemon[2622]: adding removable location: volume_uuid_60B4_A7FD at /media/NIKON D70
Jun 11 22:14:02 mpiermar-pc pulseaudio[2767]: alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write!
Jun 11 22:14:02 mpiermar-pc pulseaudio[2767]: alsa-sink.c: Most likely this is a bug in the ALSA driver 'snd_hda_intel'. Please report this issue to the ALSA developers.
Jun 11 22:14:0

*** This bug has been marked as a duplicate of bug 485734 ***

Note You need to log in before you can comment on or make changes to this bug.