Bug 504173 - Cronometer crashes KDE session; please add cronometer to Fedora
Cronometer crashes KDE session; please add cronometer to Fedora
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: fedora-marketing (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Colin Charles
Jack Aboutboul
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-04 11:19 EDT by Linuxguy123
Modified: 2010-01-09 18:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-26 15:10:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linuxguy123 2009-06-04 11:19:05 EDT
Description of problem:

a) Please ad the cronometer application to the Fedora repositories.

http://spaz.ca/cronometer/

Cronometer is a program for tracking fitness information and goals.  It can be used to monitor diet, keep a training log and track and plot various target biomarkers.  (It ships with only a few biomarkers, but one can easily edit the xml file to add however many one wants...) 

I've been using Cronometer for about a year now.  Other than the recently found bug below, its been totally stable.

b) cronometer crashes my kde sessions.

Version-Release number of selected component (if applicable):

cronometer: 0.95

$ rpm -q kmod-nvidia
kmod-nvidia-180.51-1.fc10.5.i686

$ rpm -q kdebase
kdebase-4.2.3-1.fc10.i386


How reproducible:

It was every time until yesterday.   Yesterday I ran cronometer with no problems.   Today it crashed the session again.

I believe the problem appeared with kde 3.2.3.  It ran fine on kde 3.2 before that. 

Steps to Reproduce:
1. Install cronometer
2. Run it.   
3. Move the application around a bit.

  
Actual results:

It looks like it corrupts the redrawing of the screen.  Mouse function is affected too... or at least it seems to be.  Maybe its just a redraw thing.

The only way to save the machine from crashing outright is to immediately exit the session.

I believe cronometer uses the Swing library.   Are other Swing applications experiencing the same problem ?

Expected results:

It should run without crashing the session.

Additional info:

It was stated that this is probably a problem with kmod-nvidia.   I'm actually doubting that because the whole system becomes unstable, ie mouse and keyboard response is impaired too.

I know I haven't tagged this to the right Fedora component.  I didn't know where to place a request for a new component. 

I know I should have separate bug entries for the request to add cronometer and fixing the crash, but a) then we would have 2 mis-tagged entries and b) the bug will need to be fixed before cronometer is added to the repository.

Thanks for listening.
Comment 1 Linuxguy123 2009-09-26 10:54:01 EDT
This is still an issue in F11.  Even worse, in fact.   Cronometer now locks up my session to the point that I have to do a hard reboot by powering down.

I tested Cronometer in a Gnome session on my laptop and it seems to work just fine.  It didn't crash in the 10 minutes that I entered data and looked at charts. 

$ rpm -q kdebase
kdebase-4.3.1-2.fc11.i586

$ rpm -q kmod-nvidia
kmod-nvidia-185.18.36-1.fc11.1.i586

Let me know if you need more information.
Comment 2 Michal Schmidt 2009-11-26 15:10:31 EST
(In reply to comment #0)
> a) Please ad the cronometer application to the Fedora repositories.
> 
> http://spaz.ca/cronometer/
> 
> Cronometer is a program for tracking fitness information and goals.  It can be
> used to monitor diet, keep a training log and track and plot various target
> biomarkers.  (It ships with only a few biomarkers, but one can easily edit the
> xml file to add however many one wants...)

One of the best ways to get a package into Fedora is to become a packager. See here for more information:
http://fedoraproject.org/wiki/PackageMaintainers/Join
Consider it.

If you do not wish to maintain the package yourself, try someone else who would be interested. You can add the package to the wishlist on the wiki here:
http://fedoraproject.org/wiki/PackageMaintainers/WishList

> b) cronometer crashes my kde sessions.
> $ rpm -q kmod-nvidia
> kmod-nvidia-180.51-1.fc10.5.i686
> [...]
> It looks like it corrupts the redrawing of the screen.  Mouse function is
> affected too... or at least it seems to be.  Maybe its just a redraw thing.
> [...]
> It was stated that this is probably a problem with kmod-nvidia.

This is indeed likely. Whether it's Nvidia's fault or not, the issue is impossible to debug for a Fedora developer due to the proprietary nature of the driver. Only Nvidia have the sources, and they're the only one who can help.

> I'm actually doubting that because the whole system becomes unstable, ie
> mouse and keyboard response is impaired too.

A huge part of the proprietary driver runs in kernel space, where it can do absolutely anything. Severe system instability included.

Try to reproduce the problem without using the proprietary driver. Use nouveau, nv, or vesa instead. If you can reproduce it then, please file a new bug against the respective xorg-x11-drv-* component.
Comment 3 Linuxguy123 2010-01-09 18:05:11 EST
I was not able to run nouveau on my computer.  See https://bugzilla.redhat.com/show_bug.cgi?id=528188

Good news though... the issue has disappeared.  I was able to run Cronometer version 0.95 without any issue.  I then updated and was able to run 0.97 as well.  Both work fine.

Note You need to log in before you can comment on or make changes to this bug.