Bug 504180 - surround sound doesn't work for snd-hda-intel : ALC 861
surround sound doesn't work for snd-hda-intel : ALC 861
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-06-04 12:01 EDT by Michal Hlavinka
Modified: 2010-06-28 08:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-06-28 08:48:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
alsa-info for snd-hda-intel model=asus (20.99 KB, text/plain)
2009-06-04 12:01 EDT, Michal Hlavinka
no flags Details

  None (edit)
Description Michal Hlavinka 2009-06-04 12:01:29 EDT
Created attachment 346564 [details]
alsa-info for snd-hda-intel model=asus

Description of problem:
In short:
no snd-hda-intel model=XXX option works for soundcard in laptop Asus A6T. By default, only stereo works. With model=asus or 3stack or 3stack-660 more channels works but they are wrongly wired and no sound goes to headphone connector (it only mutes the front left+right sound).

Long description:
First, I've tried to get surround sound working with pulseaudio, but setting channels = 6 produced message (something like) alsa-util.c: sound card doesn't allow 6 channels, using 2. But this was simply wrong.

I've removed everything pulseaudio related and tried to get it working with alsa only. There are several forums discussing badly working snd-hda-intel soundcards using different ALC XYZ chips (manufactured by intel/realtek), but usually with conclusion like: with model=XYZ it works. 

For ALC861 I've tried:

3stack, 3stack-dig, 6stack-dig, 3stack-660, uniwill-m31, toshiba, asus, asus-laptop, 3stack-660-digout, lenovo, dallas, hp, auto

and none of them works. It seems this card is not so spread among users:

00:10.1 Audio device [0403]: nVidia Corporation MCP51 High Definition Audio [10de:026c] (rev a2)

dmesg contains (without option model to snd-hda-intel):
HDA Intel 0000:00:10.1: PCI INT B -> Link[LAZA] -> GSI 21 (level, low) -> IRQ 21
HDA Intel 0000:00:10.1: setting latency timer to 64
hda_codec: Unknown model for ALC861, trying auto-probe from BIOS...
ALSA sound/pci/hda/hda_codec.c:3507: autoconfig: line_outs=1 (0xb/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3511:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3515:    hp_outs=1 (0xe/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3516:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3524:    inputs: mic=0xd, fmic=0x0, line=0xc, fline=0x0, cd=0x11, aux=0x0

With model=asus or 3stack or 3stack-660 more channels works but they are wrongly wired and no sound goes to headphone connector (it only mutes the front left+right sound).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.create /etc/modprobe.d/sound.conf containing:
options snd-hda-intel model=asus
2.reload snd-hda-intel module or reboot
3.check nothing from front, master, headphon, pcm, front, surround, center, lfe is muted, set channel to 6ch
4.speaker-test -Dplug:surround51 -c6 -twav

Actual results:
front left/right - no sound
rear left/right - sound
center - sound (but low volume)
lfe - sound in center again (low volume)
when nothing is plugged in headphone jack, front left/right sound works normaly from built-in speakers

Expected results:
working 5.1 sound

Additional info:
Comment 1 Bug Zapper 2010-04-27 10:39:34 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 2 Bug Zapper 2010-06-28 08:48:39 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.