Bug 504189 - shouldn't java-1.6.0-openjdk be removed from epel repos?
shouldn't java-1.6.0-openjdk be removed from epel repos?
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
ActualBug
: Reopened
Depends On: 499079
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-04 13:01 EDT by Rex Dieter
Modified: 2009-12-12 20:21 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-12 20:21:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2009-06-04 13:01:58 EDT
Now that java-1.6.0-openjdk is in rhel5 (since 5.3 it seems), shouldn't be removed from epel-5 repos?

There's another issue that epel's newest version,
java-1.6.0-openjdk-1.6.0.0-1.0.b12.el5.2

trumps rhel5's,
java-1.6.0-openjdk-1.6.0.0-0.30.b09.el5 (latest in updates that I can find atm).
Comment 1 Lubomir Rintel 2009-06-04 17:06:34 EDT
Thanks for your report.
Please go complain at your operating system vendor.

*** This bug has been marked as a duplicate of bug 498967 ***
Comment 2 Rex Dieter 2009-06-04 17:55:22 EDT
OK, I care less about the upgrade path versioning issues.

Fact remains, the existence of it in the epel repos continues to override a core rhel package... a policy violation.  

It was pointed out to me on irc that rhel's packaging doesn't include the browser plugin portion, so that part could well remain without conflict.
Comment 3 Rex Dieter 2009-06-05 08:54:16 EDT
For reference, the policy I refer to is: http://fedoraproject.org/wiki/EPEL/GuidelinesAndPolicies#Policy

"EPEL packages should only enhance and never disturb the Enterprise Linux distributions they were build for. Thus packages from EPEL should never replace packages from the target base distribution..."

So, unless I'm missing something, the path forward here is fairly simple and clear.
Comment 4 Rex Dieter 2009-06-05 09:15:28 EDT
Per maintainers preference, marking upgrade path issue as a blocker, pending policy clarifications.
Comment 5 Ralph Angenendt 2009-06-06 10:18:06 EDT
But do keep the browser plugin (which probably means that this has to be rebuilt from the RHEL version of openJDK).
Comment 6 Rex Dieter 2009-12-12 20:21:54 EST
I guess this has been taken care of... closing.

Note You need to log in before you can comment on or make changes to this bug.