Bug 504197 - bcm5974 not creating input device on Aluminium Macbook 5,1
bcm5974 not creating input device on Aluminium Macbook 5,1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: HardwareEnablement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-04 13:33 EDT by jzGreen
Modified: 2013-01-10 03:00 EST (History)
10 users (show)

See Also:
Fixed In Version: 2.6.29.5-191.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 15:23:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
synaptics hal policy (1.27 KB, application/xml)
2009-06-04 13:33 EDT, jzGreen
no flags Details
Output of 'lshal' command (130.06 KB, text/plain)
2009-06-05 12:27 EDT, jzGreen
no flags Details
Xorg.0.logOutput (43.81 KB, text/plain)
2009-06-05 13:20 EDT, jzGreen
no flags Details
Backported code (8.75 KB, patch)
2009-06-05 17:35 EDT, Matthew Garrett
no flags Details | Diff

  None (edit)
Description jzGreen 2009-06-04 13:33:14 EDT
Created attachment 346573 [details]
synaptics hal policy

Description of problem:
The trackpad does not at all function (no movement, nor click, let alone tap).
This is different to #474225 and #465677, because the track pad does not work (unconditionally).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Turn on computer
2. Boot into Fedora
3. Move finger along trackpad
  
Actual results:
No motion of cursor on screen

Expected results:
Motion of cursor on screen

Additional info:
- External USB mouse works.
- Am triple booting, and trackpad fully functional on Mac's Leopard and Windows-7 beta.
- This worked in Ubuntu and openSUSE (at the times I had them installed)
- Package xorg-x11-drv-synaptics-1.1.0-7.fc11 (i586) is installed
- Kernel Linux 2.6.29.4-167.fc11.i686.PAE    - GNOME 2.26.1

- The following was attempted but did not solve the problem... http://www.cenolan.com/2008/11/installing-fedora-10-macbook/#toc-fixing-the-touchpad

- Identical output to Bug #465677
$ /sbin/modinfo bcm5974
filename:       /lib/modules/2.6.29.4-167.fc11.i686.PAE/kernel/drivers/input/mouse/bcm5974.ko
license:        GPL
description:    Apple USB BCM5974 multitouch driver
author:         Henrik Rydberg
srcversion:     B97A6EA0304A5970714E942
alias:          usb:v05ACp0232d*dc*dsc*dp*ic03isc*ip02*
alias:          usb:v05ACp0231d*dc*dsc*dp*ic03isc*ip02*
alias:          usb:v05ACp0230d*dc*dsc*dp*ic03isc*ip02*
alias:          usb:v05ACp0225d*dc*dsc*dp*ic03isc*ip02*
alias:          usb:v05ACp0224d*dc*dsc*dp*ic03isc*ip02*
alias:          usb:v05ACp0223d*dc*dsc*dp*ic03isc*ip02*
depends:        
vermagic:       2.6.29.4-167.fc11.i686.PAE SMP mod_unload 686 
parm:           debug:Activate debugging output (int)
Comment 1 jzGreen 2009-06-05 12:27:42 EDT
Created attachment 346679 [details]
Output of 'lshal' command
Comment 2 jzGreen 2009-06-05 13:20:58 EDT
Created attachment 346686 [details]
Xorg.0.logOutput
Comment 3 Will Woods 2009-06-05 13:30:52 EDT
There's no mention of synaptics in Xorg.0.log - probably because there's nothing in HAL that has "info.capabilities" containing "input.touchpad". 

There are these two entries, but note that neither has an 'info.capabilities' entry at all:

udi = '/org/freedesktop/Hal/devices/usb_device_5ac_237_noserial_if2'
  info.bus = 'usb'  (string)
  info.parent = '/org/freedesktop/Hal/devices/usb_device_5ac_237_noserial'  (string)
  info.product = 'USB HID Interface'  (string)
  info.subsystem = 'usb'  (string)
  info.udi = '/org/freedesktop/Hal/devices/usb_device_5ac_237_noserial_if2'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'usb'  (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:04.0/usb3/3-6/3-6:1.2'  (string)
  usb.bus_number = 3  (0x3)  (int)
  usb.can_wake_up = true  (bool)
  usb.configuration_value = 1  (0x1)  (int)
  usb.device_class = 0  (0x0)  (int)
  usb.device_protocol = 0  (0x0)  (int)
  usb.device_revision_bcd = 119  (0x77)  (int)
  usb.device_subclass = 0  (0x0)  (int)
  usb.interface.class = 3  (0x3)  (int)
  usb.interface.description = 'Touchpad'  (string)
  usb.interface.number = 2  (0x2)  (int)
  usb.interface.protocol = 2  (0x2)  (int)
  usb.interface.subclass = 1  (0x1)  (int)
  usb.is_self_powered = false  (bool)
  usb.linux.device_number = 3  (0x3)  (int)
  usb.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:04.0/usb3/3-6/3-6:1.2'  (string)
  usb.max_power = 40  (0x28)  (int)
  usb.num_configurations = 1  (0x1)  (int)
  usb.num_interfaces = 3  (0x3)  (int)
  usb.num_ports = 0  (0x0)  (int)
  usb.product = 'USB HID Interface'  (string)
  usb.product_id = 567  (0x237)  (int)
  usb.speed = 12.0 (12) (double)
  usb.vendor = 'Apple, Inc.'  (string)
  usb.vendor_id = 1452  (0x5ac)  (int)
  usb.version = 2.0 (2) (double)

udi = '/org/freedesktop/Hal/devices/usb_device_5ac_237_noserial_if1'
  info.bus = 'usb'  (string)
  info.linux.driver = 'usbhid'  (string)
  info.parent = '/org/freedesktop/Hal/devices/usb_device_5ac_237_noserial'  (string)
  info.product = 'USB HID Interface'  (string)
  info.subsystem = 'usb'  (string)
  info.udi = '/org/freedesktop/Hal/devices/usb_device_5ac_237_noserial_if1'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'usb'  (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:04.0/usb3/3-6/3-6:1.1'  (string)
  usb.bus_number = 3  (0x3)  (int)
  usb.can_wake_up = true  (bool)
  usb.configuration_value = 1  (0x1)  (int)
  usb.device_class = 0  (0x0)  (int)
  usb.device_protocol = 0  (0x0)  (int)
  usb.device_revision_bcd = 119  (0x77)  (int)
  usb.device_subclass = 0  (0x0)  (int)
  usb.interface.class = 3  (0x3)  (int)
  usb.interface.description = 'Touchpad'  (string)
  usb.interface.number = 1  (0x1)  (int)
  usb.interface.protocol = 0  (0x0)  (int)
  usb.interface.subclass = 0  (0x0)  (int)
  usb.is_self_powered = false  (bool)
  usb.linux.device_number = 3  (0x3)  (int)
  usb.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:04.0/usb3/3-6/3-6:1.1'  (string)
  usb.max_power = 40  (0x28)  (int)
  usb.num_configurations = 1  (0x1)  (int)
  usb.num_interfaces = 3  (0x3)  (int)
  usb.num_ports = 0  (0x0)  (int)
  usb.product = 'USB HID Interface'  (string)
  usb.product_id = 567  (0x237)  (int)
  usb.speed = 12.0 (12) (double)
  usb.vendor = 'Apple, Inc.'  (string)
  usb.vendor_id = 1452  (0x5ac)  (int)
  usb.version = 2.0 (2) (double)
Comment 4 Matthew Garrett 2009-06-05 17:19:09 EDT
There's no input device for the trackpad, so this seems to be the kernel's fault
Comment 5 Matthew Garrett 2009-06-05 17:27:39 EDT
Needs upstream commits:

9894cf0ff5e9ccda60d8d0e2d37bd61539b08826 Input: bcm5974 - prepare for a new trackpad header type
6916d97f6e25cc66a32d6e9a16419067d843b14f Input: bcm5974 - add quad-finger tapping
158e928741e58eb4aa379da422290c10fef23f00 Input: bcm5974 - Add support for the Macbook 5 (Unibody)

for this to be properly supported - they all landed post-2.6.29.
Comment 6 Matthew Garrett 2009-06-05 17:35:59 EDT
Created attachment 346721 [details]
Backported code
Comment 7 Matthew Garrett 2009-06-05 18:14:51 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=1395933 will have a test kernel built with this, if you could give that a go.
Comment 8 jzGreen 2009-06-06 03:44:30 EDT
First installed
  kernel-PAE-2.6.30-0.97.rc8.fc12.i686.rpm
and its dependency
  kernel-firmware-2.6.30-0.97.rc8.fc12.noarch.rpm

Trackpad worked, but no wifi.


Removed, then add 2.6.29.4-167 of both.
Next installed
  kernel-PAE-2.6.29.4-168.fc11.i686.rpm

Again, trackpad works, but no wifi.

Removed broadcom-wl to attempt re-install, but all mirrors are down and cant get dependancies (am using wired connection).


Will try get more info on this over the next few days.
Comment 9 Bug Zapper 2009-06-09 13:05:25 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Eelco Hoekema 2009-06-10 14:03:25 EDT
For the Touchpad, this Ubuntu thread might be of help:
https://help.ubuntu.com/community/MacBook5-1/Intrepid#Trackpad
Comment 11 Chuck Ebbert 2009-06-15 11:10:41 EDT
Patches were added to kernel- 2.6.29.5-182.rc1
Comment 12 Fedora Update System 2009-06-17 07:53:23 EDT
kernel-2.6.29.5-191.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kernel-2.6.29.5-191.fc11
Comment 13 Fedora Update System 2009-06-19 09:43:57 EDT
kernel-2.6.29.5-191.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6768
Comment 14 Fedora Update System 2009-06-24 15:22:31 EDT
kernel-2.6.29.5-191.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.