Bug 504226 - qemu-kvm binary should support the '-curses' option
qemu-kvm binary should support the '-curses' option
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-04 16:32 EDT by Matty
Modified: 2009-06-05 05:33 EDT (History)
7 users (show)

See Also:
Fixed In Version: qemu-0.10.50-6.kvm86.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-05 05:33:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matty 2009-06-04 16:32:29 EDT
Description of problem:

The qemu-kvm option doesn't currently support the '-curses' flag:

[root@disarm ~]# uname -a
Linux disarm 2.6.27.5-117.fc10.x86_64 #1 SMP Tue Nov 18 11:58:53 EST 2008 x86_64 x86_64 x86_64 GNU/Linux

[root@disarm ~]# qemu-kvm -help | grep curses

[root@disarm ~]# qemu-kvm -curses
qemu-kvm: invalid option -- '-curses'

But the manual page shipped with fedora 10 lists this as a valid option:

      -curses
           Normally, QEMU uses SDL to display the VGA output.  With this option, QEMU can
           display the VGA output when in text mode using a curses/ncurses interface.
           Nothing is displayed in graphical mode.

Version-Release number of selected component (if applicable):

Fedora 10 with the latest KVM and Qemu packages:

[root@disarm ~]# rpm -q -a | egrep '(kvm|qemu)'
qemu-img-0.9.1-10.fc10.x86_64
kvm-74-11.fc10.x86_64
etherboot-roms-kvm-5.4.4-5.fc10.x86_64


How reproducible:

Listed above.

Steps to Reproduce:
1.  Steps are listed above.
  
Actual results:

BIOS screens and early interaction is currently unavailable from the console (you can still get to this it you enable vnc though).

Expected results:

The early boot screens should be displayed.

Additional info:

None.
Comment 1 Daniel Berrange 2009-06-04 17:51:38 EDT
This is already certainly due to the RPM missing a BuildRequires dependency on ncurses-devel. The configure script probes for curses.h and curses_version(), and automatically disables curses support if missing.
Comment 2 Mark McLoughlin 2009-06-05 05:33:47 EDT
Thanks, fixed in rawhide now with qemu-0.10.50-6.kvm86.fc12:

* Fri Jun  5 2009 Mark McLoughlin <markmc@redhat.com> - 2:0.10.50-6.kvm86
- Fix 'kernel requires an x86-64 CPU' error
- BuildRequires ncurses-devel to enable '-curses' option (#504226)

Note You need to log in before you can comment on or make changes to this bug.