Bug 504289 - unavailable dependencies breaks svn HEAD build
unavailable dependencies breaks svn HEAD build
Status: CLOSED CURRENTRELEASE
Product: Dogtag Certificate System
Classification: Community
Component: Build (Show other bugs)
1.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Harmsen
Chandrasekar Kannan
:
Depends On:
Blocks: 445047
  Show dependency treegraph
 
Reported: 2009-06-05 09:19 EDT by David Stutzman
Modified: 2015-01-04 18:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-22 15:58:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Stutzman 2009-06-05 09:19:41 EDT
Description of problem:
I'm trying to build the latest HEAD from subversion following the directions available at http://pki.fedoraproject.org/wiki/PKI_Components_Collectively_via_Subversion.  pki-util build breaks due to failed dependency on jss 4.2.6. Others will break later, this is just the first.

Version-Release number of selected component (if applicable):
Dogtag svn r552

How reproducible:
every time

Steps to Reproduce:
1. follow steps outlined on wiki page on a fedora 8-10 box
  
Additional info:
Apparently JSS 4.2.5 is the most-current JSS available on fedora 8, 9 or 10.  So it is currently impossible to build the latest version of Dogtag.
Comment 1 Matthew Harmsen 2009-06-05 12:20:54 EDT
I have placed a temporary JSS 4.2.6 in the Dogtag repo until such time as it can be updated in Koji (which is currently in progress).  This can be obtained by making certain that you have enabled the latest Dogtag 1.1 yum repo:

    cd /etc/yum.repos.d
    wget http://pki.fedoraproject.org/pki/download/pki/1.1.0/pki.repo

Note You need to log in before you can comment on or make changes to this bug.