Bug 504368 - Broken link after enabling Virtualization entitlement on a system
Broken link after enabling Virtualization entitlement on a system
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
Preethi Thomas
:
Depends On:
Blocks: 456984 456985
  Show dependency treegraph
 
Reported: 2009-06-05 16:13 EDT by Jay Dobies
Modified: 2009-08-20 14:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-08 14:03:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Success message with help link (163.11 KB, image/png)
2009-06-05 16:15 EDT, Jay Dobies
no flags Details

  None (edit)
Description Jay Dobies 2009-06-05 16:13:26 EDT
Description of problem:
After enabling virt entitlements on a system, I see a confirmation message at the top:

Since you added a Virtualization entitlement to the system we also performed some extra steps to ensure your system will be able to manage virtual guests better. See here for more info.

The "here" link points to: /rhn/help/reference/en-US/ch-virtualization.jsp

Clicking on that link gives a 404.

Version-Release number of selected component (if applicable):
5.3

How reproducible:
Always

Steps to Reproduce:
1. Enable virt entitlements on a system
2. Click the "here" link in the resulting success confirmation message
  
Actual results:
Page Not Found

Expected results:
Help page.

Additional info:
Comment 1 Jay Dobies 2009-06-05 16:15:56 EDT
Created attachment 346713 [details]
Success message with help link
Comment 2 Clifford Perry 2009-06-08 11:35:07 EDT
Brad has been fixing broken links, maybe this one missed his grep. 

Please take a look Brad. 

Cliff
Comment 3 Brad Buckingham 2009-06-08 14:03:55 EDT
Using satellite-embedded-oracle-5.3.0-20090506-rhel-5-i386.iso, I am able to access the documentation at:

   https://<server>/rhn/help/reference/en-US/ch-virtualization.jsp

It appears that the system under test was missing content for the documentation under /var/lib/tomcat5/webapps/rhn/help.  For now, going to close the bugzilla; however, it can be reopened, if needed.
Comment 4 Jay Dobies 2009-08-20 14:02:33 EDT
Double checked against stage, this was just an issue with my local setup at one point.

Note You need to log in before you can comment on or make changes to this bug.