Bug 504427 - Display corruption with radeon driver: [drm] wait for fifo failed status : 0xA27334AC 0x00000103
Display corruption with radeon driver: [drm] wait for fifo failed status : 0x...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Jérôme Glisse
Fedora Extras Quality Assurance
card_**** FULLSTRING: ATI Radeon HD 3...
: Triaged
: 567938 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-06 17:47 EDT by Dawid Zamirski
Modified: 2010-06-28 08:49 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:49:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (49.85 KB, text/plain)
2009-06-06 17:56 EDT, Dawid Zamirski
no flags Details
Xorg.0.log (105.63 KB, text/plain)
2009-06-06 17:56 EDT, Dawid Zamirski
no flags Details
messages (652.56 KB, text/plain)
2009-06-06 17:57 EDT, Dawid Zamirski
no flags Details

  None (edit)
Description Dawid Zamirski 2009-06-06 17:47:08 EDT
Description of problem:
My screen gets corrupted and the system becomes unusable (although it's responsive via SSH from another machine) whenever I watch some flash video (especially on youtube) or when I view a few of my pictures using the gnome's image viewer in full screen. 

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.12.2-14.fc11.x86_64
xorg-x11-drivers-7.3-11.fc11.x86_64
xorg-x11-apps-7.3-8.fc11.x86_64
xorg-x11-server-utils-7.4-7.fc11.x86_64
xorg-x11-drv-glint-1.2.2-2.fc11.x86_64
xorg-x11-server-common-1.6.1.901-1.fc11.x86_64
xorg-x11-utils-7.4-4.fc11.x86_64
xorg-x11-drv-evdev-2.2.1-3.fc11.x86_64
xorg-x11-drv-mouse-1.4.0-2.fc11.x86_64
xorg-x11-drv-apm-1.2.1-2.fc11.x86_64
xorg-x11-server-Xorg-1.6.1.901-1.fc11.x86_64
xorg-x11-xinit-1.0.9-7.fc11.x86_64
xorg-x11-xauth-1.0.2-6.fc11.x86_64
kernel-2.6.29.4-167.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open gnome viewer in full screen and view some pictures in this mode. 
2. After a while (10-15) picture the whole screen gets corrupted and machine becomes unusable - the system is still responsive via ssh 
3. [drm] wait idle status failed or [drm] wait for fifo failed status messages appear in dmesg
  
Actual results:
Corrupted screen and machine is unusable.

Expected results:
No screen corruption.

Additional info:
This has been happening since F11 beta but I couldn't reliably reproduce it and capture any error messages until I realized I could SSH from my laptop and look into dmesg. I will attach dmesg and Xorg.log

My hardware:
MSI 790GX-G65 motherboard
Viedo: Integrated RadeonHD 3300
Comment 1 Dawid Zamirski 2009-06-06 17:56:33 EDT
Created attachment 346759 [details]
dmesg output
Comment 2 Dawid Zamirski 2009-06-06 17:56:55 EDT
Created attachment 346760 [details]
Xorg.0.log
Comment 3 Dawid Zamirski 2009-06-06 17:57:59 EDT
Created attachment 346761 [details]
messages
Comment 4 Ekimov Alexandr 2009-07-02 16:13:37 EDT
I have the same symptoms: screen gets corrupted, X-window becomes unusable and messages "[drm] wait for fifo failed status : 0xE00014AC 0x00100003" in logs
I build radeon and radeonhd from git, but the same result.

Hardware:
My hardware includes Integrated RadeonHD 3300 too.
motherboard: ASUS m4a78t-e
lspci:
00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
00:01.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (int gfx)
00:06.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2)
00:07.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 3)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3a)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Link Control
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon HD 3300 Graphics
01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller
02:00.0 Ethernet controller: Attansic Technology Corp. Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller (rev b0)
03:00.0 FireWire (IEEE 1394): VIA Technologies, Inc. Device 3403
04:05.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 62)
04:05.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 62)
04:05.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 65)
04:06.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
Comment 5 Nivag 2009-07-14 19:55:08 EDT
I have the same Integrated Radeon HD 3300 chipset.

My motherboard is also an M4A78T-E - relates to: Comment #4 From  Ekimov Alexandr.

I wonder if the following bugs I raised below, are related to the problem raised in this bug - though none of them actually corrupt the screen (except possibly 510656).  However, note that I usually work from my another work station and ssh into the problem machine, so I may not have noticed any screen corruption.

510482 	unable to handle kernel paging request - radeon_read_ring_rptr
510485 	general protection fault - radeon_read_ring_rptr 
510656 	gdm greeter missing after hibernate
510981 	gdm stack trace after drm Resetting GPU

Each of the above bugs, has details from the messages log, and other possibly useful diagnostics.
Comment 6 Ekimov Alexandr 2009-07-27 07:04:10 EDT
If disable onboard video memory(called SIDEPORT) and use ONLY system memory as video memory(in BIOS called UMA) problem disappeared.
Comment 7 Dawid Zamirski 2009-07-27 23:47:29 EDT
Disabling sideport and switching to UMA only in BIOS seems to resolve the issue for me as well. Thanks Ekimov for the tip!
Comment 8 Ekimov Alexandr 2009-07-29 05:01:48 EDT
I got answer from radeon driver developer, Alex Deucher: "sideport isn't supported at the moment."
Comment 9 Nivag 2009-07-29 20:15:53 EDT
What is the relevance, if any, of comments #6,7,8 have to the 
Bug 488940 -  kernel BUG/X hangs in radeon_read_ring_rptr ?

I have disabled SidePort and switched to UMA in the BIOS.

I can go 2 or 3 days without a problem with the radeon driver, then have several severe problems with it in a the space of a couple of hours.  So it will be a while before I can suggest that disabling SidePort will help in that area, even then it would not be conclusive.

I am happy to run experimental software, or to provide additional diagnostics; should that help resolve the issues.
Comment 10 Nivag 2009-08-07 18:55:47 EDT
I have not had any further problems with the radeon driver, since I disabled SidePort and switched to UMA in the BIOS - as per Comment #9 above.
Comment 11 Paul J. Reder 2009-08-17 11:20:12 EDT
Can anyone tell me what performance impact results from turning off the use
of sideport memory and when a fix might be available to add support?

I've disabled sideport and my crashes have gone away, but I'd like sideport back
if it will improve performance.
Comment 12 Ekimov Alexandr 2009-08-18 12:25:57 EDT
>if it will improve performance.  
It's increase available video memory only. it's memory module on motherboard.
Comment 13 Matěj Cepl 2009-11-05 13:30:48 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 14 Dawid Zamirski 2009-12-02 21:29:07 EST
This is still an issue in up-to-date Fedora 12. Of course, I wasn't even expecting it to be solved as there was no work done to enable sideport support in the radeon driver and I'm just responding to the bug triage messege.
Comment 15 Curt Timmerman 2009-12-07 09:54:27 EST
This problem is definitely still not fixed. It's actually worse in Fedora 12 - the corruption is occurring spontaneously now.

My Fedora 12 is up to date as of: 12/7/09.
Comment 16 Ekimov Alexandr 2010-01-06 16:50:32 EST
With kernel 2.6.32 and mesa 7.7 sideport memory works for me. And basic 3D too.
Comment 17 Dawid Zamirski 2010-01-09 16:45:13 EST
(In reply to comment #16)
> With kernel 2.6.32 and mesa 7.7 sideport memory works for me. And basic 3D too.    

Confirmed, after I got the new libdrm and xorg packages (I did not update the kernel) from updates-testing, this issue seems to be gone. At least I can't trigger it using the full screen picture browsing test case that I was previously using. I have also did some tests with youtube videos and all seems to work fine.
Comment 18 Matěj Cepl 2010-02-24 10:54:44 EST
*** Bug 567938 has been marked as a duplicate of this bug. ***
Comment 19 Nigel Jones 2010-02-24 11:52:50 EST
NOte the above defect (occurred to me today), marked as a dup of this one is on a Thinkpad W500 using the ATI V5700 gfx with a 2nd monitor attached via DVI.

The issue occurs with 2.6.32, but does not occur using 2.6.31 kernel. It also does not occur if KMS is disabled

I have applied all current kernel/mesa/radeon updates from updates-testing.
Comment 20 todorz 2010-04-21 15:53:32 EDT
Same issue with Thinkpad W500 with the integrated ATI V5700/HD3650 as above. Latest kernel 2.6.32.11-99.fc12.x86_64 and updates. When docked using VGA and DVI, the output on the DVI monitor is distorted. There's a rather annoying workaround to get the distorted output on the DVI connected monitor fixed but the system will randomly lock up shutting off both displays.

To fix the distorted display, open Display preferences:
1. Change the resolution on the affected (DVI) screen to a lower resolution
2. Disable the second screen (VGA)
3. Enable Laptop display
4. Apply and Keep configuration
5. Set the resolution on the previously distorted (DVI) screen appropriately
6. Enable second screen (VGA)
7. Disable Laptop display
8. Apply and Keep configuration

To fix the distorted display AND avoid system lockups I added 'nomodeset' to the kernel options as advised at https://fedoraproject.org/wiki/Common_F12_bugs
I had the 'nomodeset' fix in for about a week now and haven't experienced any lockups.

I managed to get the following errors from the X log once:
[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x49ec58]
1: /usr/bin/Xorg (mieqEnqueue+0x1f4) [0x49e624]
2: /usr/bin/Xorg (xf86PostMotionEventP+0xce) [0x4791ee]
3: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7fd6cc362000+0x516f) [0x7fd6cc36716f]
4: /usr/bin/Xorg (0x400000+0x6c0d7) [0x46c0d7]
5: /usr/bin/Xorg (0x400000+0x1173c3) [0x5173c3]
6: /lib64/libpthread.so.0 (0x3ac8400000+0xf0f0) [0x3ac840f0f0]
7: /lib64/libc.so.6 (ioctl+0x7) [0x3ac7cd6937]
8: /usr/lib64/libdrm.so.2 (drmIoctl+0x23) [0x3371003383]
9: /usr/lib64/libdrm.so.2 (drmCommandWriteRead+0x1c) [0x33710035cc]
10: /usr/lib64/libdrm_radeon.so.1 (0x7fd6ccfb4000+0x1469) [0x7fd6ccfb5469]
11: /usr/lib64/libdrm_radeon.so.1 (0x7fd6ccfb4000+0x14b4) [0x7fd6ccfb54b4]
12: /usr/lib64/xorg/modules/drivers/radeon_drv.so (0x7fd6cd1da000+0xb9050) [0x7fd6cd293050]
13: /usr/lib64/xorg/modules/libexa.so (0x7fd6cc56c000+0x8308) [0x7fd6cc574308]
14: /usr/bin/Xorg (0x400000+0x1534f4) [0x5534f4]
15: /usr/bin/Xorg (0x400000+0x2e070) [0x42e070]
16: /usr/bin/Xorg (0x400000+0x2c7bc) [0x42c7bc]
17: /usr/bin/Xorg (0x400000+0x21d8a) [0x421d8a]
18: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x3ac7c1eb1d]
19: /usr/bin/Xorg (0x400000+0x21949) [0x421949]
Comment 21 Bug Zapper 2010-04-27 10:41:00 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 22 Bug Zapper 2010-06-28 08:49:21 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.