Bug 504452 - Serial printing: Problems with datasource refresh, selection of records when printing to a file
Serial printing: Problems with datasource refresh, selection of records when ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
11
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-07 02:56 EDT by Wolfram Wagner
Modified: 2009-08-31 19:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.1.1-19.1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 19:32:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example file. (6.50 KB, application/vnd.ms-excel)
2009-06-28 16:23 EDT, Wolfram Wagner
no flags Details
same problem with ods (8.40 KB, application/vnd.oasis.opendocument.spreadsheet)
2009-06-28 16:24 EDT, Wolfram Wagner
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 102932 None None None Never

  None (edit)
Description Wolfram Wagner 2009-06-07 02:56:13 EDT
Description of problem:
I found these problems in several situations with three different serial letters. It makes working hard => impossible.
The mail merger wizard is working, although it is not doing what I want.

Please consider those problems as prio high together with the other bug that I filed before, it makes using oo for serial letters almost impossible. I am still very positive about open office, but it is more important to prevail the existing functionality, than to improve usage. 

(1) Using a spreadsheet (ods) as data source, it is not possible to use it directly after saving as source for database fields in a letter. The columns are simply not displayed in field selection window.
(spreadsheet saved, closed, reopened, saved in edit mode, saved in view mode, closed again, waited 15 minutes, => no difference; used mail merger wizard to insert fields, tried to insert them directly => impossible)

(2) When I take an older spreadsheet I can create my spreadsheet though. But changes are not reflected immediately.

(3) When I try to print the letter into one file (for review) and choose a range via the index (from record => to record) I get a one page letter without field content. Selection via highlighting and "print selected" works.

Version-Release number of selected component (if applicable):
I am running the preview version of Fedora 11 (ooo 3.1.0-10.2, problem exists also 10.3).


How reproducible:


Steps to Reproduce:
(1) 
1.create an ods with a simple address list
2.create a text file and try to add fields from (1)

(2) 
Cannot provide an reproducable example, because I am stuck at (1)

(3)
Use an existing serial letter setup, print, yes serial letter, choose a sequence of records print, check file => nothing in it
Try to print all, print the highlighted selection => works
Comment 1 David Tardon 2009-06-08 02:35:24 EDT
Confirmed, printing of a sequence doesn't work.

To the step (1)/2: the following steps work for me:

1. Insert->Field->Other...
2. select table Database
3. add the database file
4. set Type to 'Mail merge fields'

Columns of Sheet1 of the database file are available now.
Comment 2 David Tardon 2009-06-19 02:40:55 EDT
Fix checked in to F-11 and Rawhide. Will be in >=3.1.0-11.4 and >=3.1.1-13.3, respectively.
Comment 3 Fedora Update System 2009-06-23 03:38:37 EDT
openoffice.org-3.1.0-11.4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.0-11.4.fc11
Comment 4 Fedora Update System 2009-06-26 22:53:13 EDT
openoffice.org-3.1.0-11.4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7003
Comment 5 Wolfram Wagner 2009-06-28 16:08:09 EDT
Bug (3) works now for me. I have had no time to check the remaining points. Will come back.
Comment 6 Wolfram Wagner 2009-06-28 16:22:52 EDT
(1) Open: 
- I have created a spread sheet, with two addresses
- created a text document, insert fields, database fields, searched for the spread sheet => NO possible fields are displayed

I create an attachment that contains the xls spreadsheet. Same for ods too.

So this bug should still be open!!!
Comment 7 Wolfram Wagner 2009-06-28 16:23:33 EDT
Created attachment 349713 [details]
example file.
Comment 8 Wolfram Wagner 2009-06-28 16:24:04 EDT
Created attachment 349714 [details]
same problem with ods
Comment 9 David Tardon 2009-06-29 02:30:12 EDT
(In reply to comment #6)
> (1) Open: 
> - I have created a spread sheet, with two addresses
> - created a text document, insert fields, database fields, searched for the
> spread sheet => NO possible fields are displayed

Four fields are displayed when using the .ods file supplied by you. Do you have openoffice.org-base installed?

> So this bug should still be open!!!  

Please, abstain from using too many exclamation marks--one is enough. You can always reopen the bug if you think it hasn't been fixed; it's just I don't see the problem you're describing.
Comment 10 Wolfram Wagner 2009-06-29 14:40:57 EDT
David,

Sorry, I didn't want to offend you... I was tired, my kids where crying and I simply could not find the fields...
I am very sorry!

After all I found out, what I made wrong. 

On left side of database/field selection there was "record number" selected. So I saw no fields. Shame on me... sorry.

These issues are gone. Close this bug. Thank you!

PS: one last question: It is necessary to save the database files in home directory? Hows about somewhere in .openoffice.org/ or to ask where to place them?
Comment 11 David Tardon 2009-06-30 04:00:54 EDT
(In reply to comment #10)
> Sorry, I didn't want to offend you... I was tired, my kids where crying and I
> simply could not find the fields...
> I am very sorry!

No worry! I'm not so easy to offend :)

> These issues are gone. Close this bug. Thank you!

Great! As for closing the bug: it will get closed automatically, after the update is pushed as stable to F-11.

> 
> PS: one last question: It is necessary to save the database files in home
> directory? Hows about somewhere in .openoffice.org/ or to ask where to place
> them?  

I must admit it sligtly annoys me too... I'm going to look at it someday. But I think asking user is not the right way; the process should be tranparent.
Comment 12 Wolfram Wagner 2009-06-30 07:52:02 EDT
> But I think asking user is not the right way; the process should be tranparent.  

I aggree. But if they are hidden, they need to be pruned too. Currently the unused, "delete"d database files stay forever. After my test I had many database files in my home dir...
Thanks again!
Comment 13 Fedora Update System 2009-07-10 03:53:40 EDT
openoffice.org-3.1.0-11.5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.0-11.5.fc11
Comment 14 Fedora Update System 2009-07-16 03:06:01 EDT
openoffice.org-3.1.0-11.5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7604
Comment 15 Fedora Update System 2009-08-29 05:41:17 EDT
openoffice.org-3.1.1-19.1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.1.fc11
Comment 16 Fedora Update System 2009-08-31 19:31:39 EDT
openoffice.org-3.1.1-19.1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.